Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I maintain a small network for an accounting office. My client has a Windows 7 Professional server which is sharing Internet access and sharing a folder to 2 Windows 7 workstations and 2 Windows XP workstations. I have the folder mapped as drive "L:" on all the workstations.

Everything works fine for the Windows 7 workstations. They are able to access the Internet and read/write files in the shared folder all day, every day.

Everything works fine for the Windows XP workstations at first, but then they lose access to the shared folder after awhile (sometimes hours, sometimes overnight). They retain access to the Internet, however. I am sometimes able to reboot the Windows XP workstations to see the shared folder again, but other times the connection just comes and goes at an apparently random schedule.

Here's what I've done to try to address this. Some of these seem unrelated to my problem, but I'm desperate for a fix.

  • All workstations and the server are on the same workgroup.
  • Password-protected sharing is enabled on the server and all workstations and the server have the same user names and passwords.
  • Firewalls are properly configured (using Windows firewall which MS says is automatically configured when you turn on sharing) and turning off firewalls doesn't fix the problem.
  • The network on the shared side of the server is set to "Work" (although it is an "Unidentified network" because I don't have a router installed).
  • Advanced properties on the server are set to "Enable NetBIOS over TCP/IP" (it had been "Default")
  • The server is my workgroup's master browser.
  • Power saving on the server's network cards is turned off, so they never power down.

I have looked and looked for the solution to this, but haven't found it so far. I thought it would be related to the firewall or the master browser, but I haven't found that to be the case so far. Please let me know if you have any other ideas. Thank you in advance!

share|improve this question
    
Have you looked in the Event Viewer on both systems? If you see errors, start by googling for those error messages. –  jftuga Feb 13 '11 at 18:55
    
I hadn't examined the Event Viewer very carefully, but excellent suggestion. I found quite a few "Event 2017, srv" errors, saying nonpaged-pool memory couldn't be allocated. I found this post on tweaking memory allocation in Windows 7 and am hoping that it fixes my problem. –  Knute Knudsen Feb 13 '11 at 21:21

1 Answer 1

up vote 4 down vote accepted

Browsing the Event Viewer on the server was the key to solving this issue (thanks, jftuga). After seeing the "srv 2017" errors, a web search revealed this problem to be pretty old with dozens of references to the apparent solution. It seems that Alan LaMielle should get credit for posting the solution first.

The Solution

First, make the following registry changes:

Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Memory Management]
"LargeSystemCache"=dword:00000001

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\LanmanServer\Parameters]
"Size"=dword:00000003

Then, restart the server (or reboot):

net stop server
net start server

About The Solution

In some other versions of Windows, there is an option in the Network section of Control Panel for optimizing the Server for file-sharing. In Windows 7, you have to make the registry changes yourself. Although Alan LaMielle helped many Windows 7 users figure this out, it had previously been described in Microsoft's How to Optimize Windows NT Server Using the Registry:

When you configure one of the four options for the Server service, the information is saved to the following two registry keys:

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\lanmanserver\parameters\size

Your choices for this registry key are 1, 2 and 3.
    1 = Minimize Memory Used
    2 = Balance
    3 = Maximize Throughput for File Sharing and Maximize
        Throughput for Network Applications

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\SessionManager\MemoryManagement\LargeSystemCache

Your choices for this registry key are 0 and 1.
    1 = Maximize Throughput for File Sharing
    0 = Maximize Throughput for Network Applications
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.