Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to set up a VPN server using OpenVPN and I'm getting some errors while trying to connect the client to the server. I'm getting the following error:

Sun Feb 13 14:54:16 2011 OpenVPN 2.1.4 i686-pc-linux-gnu [SSL] [LZO2] [EPOLL] built on Feb  5 2011
Sun Feb 13 14:54:16 2011 IMPORTANT: OpenVPN's default port number is now 1194, based on an official port number assignment by IANA.  OpenVPN 2.0-beta16 and earlier used 5000 as the default port.
Sun Feb 13 14:54:16 2011 NOTE: OpenVPN 2.1 requires '--script-security 2' or higher to call user-defined scripts or executables
Sun Feb 13 14:54:16 2011 ******* WARNING *******: all encryption and authentication features disabled -- all data will be tunnelled as cleartext
Sun Feb 13 14:54:16 2011 RESOLVE: NOTE: localhost resolves to 2 addresses
Sun Feb 13 14:54:16 2011 Note: Cannot ioctl TUNSETIFF tap0: Device or resource busy (errno=16)
Sun Feb 13 14:54:16 2011 Note: Attempting fallback to kernel 2.2 TUN/TAP interface
Sun Feb 13 14:54:16 2011 Cannot open TUN/TAP dev /dev/tap0: No such file or directory (errno=2)
Sun Feb 13 14:54:16 2011 Exiting

I have bridge-utils installed and tap0 shows up in ifconfig. Can anybody give me a hand? Thanks in advance.

share|improve this question
    
OK, we'll need to know what OS you are running on. Other than that it's just a matter of working through the error messages: why is there no encryption? And start investigating tun0 or /dev/tap0 on your OS. Start with the man pages :-) –  DutchUncle Feb 13 '11 at 22:57
    
Thanks for the response. I'm currently running Ubuntu 10. I have no idea why the encryption features are disabled, I'm assuming a missing or invalid entry in the config, I figured I could go back and look at that later. –  bkrupa Feb 14 '11 at 4:59
    
I'm not sure if this helps at all but I used the Client and Server tutorials from help.ubuntu.com/community/OpenVPN and that error message appeared when I was trying to connect locally. –  bkrupa Feb 14 '11 at 5:10
    
it looks like the tutorial you are following is incomplete, as they do expect a single tun to be configured on the OS. Also, maybe the default setup does no allow for 'internal' (i.e. LAN) tunnels. You normally only accept VPN tunnels on the 'external' network interface. –  DutchUncle Feb 14 '11 at 20:28
    
I figured that the local connection might be causing an issue but I didn't think that it would be fatal in this way. Any advice on where to go from here? –  bkrupa Feb 14 '11 at 21:41

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.