Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

on a test server I have installed the latest version of Confluence. I configured a apache with ajp. But I have a problem, when I login in Confluence, I get the following error message:

Not Found
The requested URL / / homepage.action was not found on this server.

The problem seems to be known, I found following Link:

But unfortunately the forwards have not helped, I still get the error messages. Does anyone have any idea how I could solve the problem?

The following Apache configuration I have set up:

LoadModule proxy_module /usr/lib/apache2/modules/
LoadModule proxy_http_module /usr/lib/apache2/modules/
LoadModule proxy_ajp_module /usr/lib/apache2/modules/

<IfModule proxy_http_module>
ProxyRequests Off
ProxyPreserveHost On

<Proxy *>
Order deny,allow
Allow from all

<Location />
Order allow,deny
Allow from all

ProxyPass / http://localhost:8080/
ProxyPassReverse / http://localhost:8080/

share|improve this question

Your configuration, on the face of it, looks correct, assuming that Confluence is installed and Tomcat is properly configured.

On your server, what do you get if you type this:

curl -D /dev/stderr http://localhost:8080/

And how about this:

curl -D /dev/stderr http://localhost:8080/homepage.action

You said:

I configured a apache with ajp.

Please note that at the moment you're not using ajp. You're proxying using http://; if you were to use ajp, your configuration would look like this:

ProxyPass / ajp://localhost:8009/
ProxyPassReverse / ajp://localhost:8009/

However, this shouldn't substantially affect your problem (for simple operation, accessing tomcat over with http or ajp gets you to the same place).

EDIT: The output from curl that you provided demonstrates that Confluence is responding at the correct URLs. In fact, if I take your Apache configuration and drop it verbatim onto my server, it works just fine.

When you attempt to connect to http://yourserver/, what shows up in the Apache access log? Error log?

share|improve this answer

thanks for your Post. I execute the commands and get this:

1) curl -D /dev/stderr h**p://localhost:8080/

HTTP/1.1 302 Moved Temporarily
Server: Apache-Coyote/1.1 
Set-Cookie: JSESSIONID=838E3DA5D23E1457669E843CA2CFBBBA; Path=/; HttpOnly
Location: http://localhost:8080/homepage.action
Content-Type: text/html
Content-Length: 0
Date: Mon, 14 Feb 2011 21:42:49 GMT

2) curl -D /dev/stderr h**p://localhost:8080/homepage.action

HTTP/1.1 302 Moved Temporarily
Server: Apache-Coyote/1.1
Cache-Control: no-cache, must-revalidate 
Expires: Thu, 01 Jan 1970 00:00:00 GMT
X-Confluence-Request-Time: 1297720104335
Set-Cookie: JSESSIONID=F6941E06E83ABB538A8341181AED3E6A; Path=/; HttpOnly
Location: http://localhost:8080/login.action;jsessionid=F6941E06E83ABB538A8341181AED3E6A?os_destination=%2Fhomepage.action
Content-Type: text/html;charset=UTF-8
Content-Length: 0
Date: Mon, 14 Feb 2011 21:48:24 GMT

Honestly I have no idea what to do with the "curl" output.

You're right, usually I use the port 8009 with the AJP-Proxy, but there is no AJP-connector on Confluence, and I did not want to install a extra connetor. I also think so, that's not the reason for the Problem.

share|improve this answer
FYI: You usually want to update your question, rather than adding this as an answer. – larsks Feb 14 '11 at 22:14

in the apache error_log isn´t anything, and in the apache acces_log appears only this line when I log in:

IP-Adress - - [16/Feb/2011:18:02:14 +0100] "POST /dologin.action HTTP/1.1" 302 724 "" "Mozilla/5.0 (xxx; U; xxx; de; rv: Gecko/20101203 Firefox/3.6.13"

share|improve this answer

I found the Problem. In apache I set a redirect from Port 80 to 443. But Confluence generate http://-Adresses. Now I change my rewrite rules from [R=301] to [R=301,NE], and it works now :)

THX for Your help.



share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.