Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a domain purchased from name.com - I am using heroku for hosting a rails app for this domain. Today I tried to setup DNS for this domain. The top level domain works fine but when I try to setup CNAME for "www", I get the following error :

ubuntu:~/rails_projects/socal$ host www.xyz.in
Host www.xyz.in not found: 3(NXDOMAIN)
('xyz' is just for example)

My CNAME settings in name.com looks like :

Record Type     Record Host     Record Answer          TTL  
CNAME           www.xyz.in      proxy.heroku.com       1800     

This is as per the instructions on heroku.com-http://devcenter.heroku.com/articles/custom- domains Not sure what could be wrong with my DNS settings

share|improve this question
add comment

2 Answers 2

up vote 0 down vote accepted

I highly suggest using a A record for www ,as a Cname will cause 2 lookups at the server doubling the load. Cnames were designed fir when you don't control the other domain, An A record is much more suited for this

share|improve this answer
    
I cant create www A record with proxy.heroku.com - I get 'Invalid character used for record answer' I will try creating with ip –  user70692 Feb 14 '11 at 13:14
    
Created A record for all heroku ips - still same error : www.socl.in 174.129.212.2 www.socl.in 75.101.145.87 www.socl.in 75.101.163.44 –  user70692 Feb 14 '11 at 13:17
    
any time lag before the changes are reflected ? –  user70692 Feb 14 '11 at 13:38
    
If you setup another record it should ask the server as it hasn't cached it yet. –  Jacob Feb 14 '11 at 13:39
    
does heroku assign you a IP or a hostname? –  Jacob Feb 14 '11 at 13:41
show 10 more comments

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.