Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

the problem is that we want to use openVPN here as default VPN Server. Now we have the same problem like everytime. On Windows all works fine but on Mac we have problems with the routing.

When you are logged on to the network all you internet traffic goes through the vpn connection. We have set routes for this in the Serverconfig but they have no effect on the target system.

Is here anybody who have a solution for this?

thx for you help

UPDATE:

I don't want that the traffic goes through the VPN connection! The problem is when anybody download a file our connection here is dead.

share|improve this question
1  
I think you need to update your questions with specific examples from your configuration...e.g., your OpenVPN client configuration, the output of "netstat -rn" after the VPN connection is up, etc. –  larsks Feb 14 '11 at 14:08

3 Answers 3

up vote 1 down vote accepted

Since this should be independent of which platform you run open-vpn on, you should be fine if you set the redirect-gateway directive on the Server.

See the openVPn howto for further details.

Update

In the question you told you set the routes. Setting the routes might or might not be the exact same thing as redirect-gateway. I can't tell without knowing your configuration. OpenVPN supports various ways to set routes according to the client system or specification.

You might also want to recheck if you've set the route-method and route-delay values.

share|improve this answer
    
I have written direct in the headline "MAC" the problem is only with MAC all other platforms run fine! We have tested the option "redirect-gateway" and nothing happen. –  Stony Feb 14 '11 at 14:21

I have OpenVPN running on OSX with Tunnelblick.

To get all the traffic go through the VPN connection, I added the following to my OpenVPN server's configuration:

push "redirect-gateway def1"

OpenVPN's (version 2.1) documentation defines "def1" as follows:

def1 -- Use this flag to override the default gateway by using 0.0.0.0/1 and 128.0.0.0/1 rather than 0.0.0.0/0. This has the benefit of overriding but not wiping out the original default gateway.

I have no other settings affecting the routing.

share|improve this answer
    
hmm i don't wont that the internet traffic goes through VPN. When anybody starts a download the internet connection is dead. –  Stony Feb 14 '11 at 17:02
    
Then maybe you need to remove the redirect-gateway definition from configs. –  oherrala Feb 15 '11 at 11:54
    
Although this is not the answer to the above question this IS the answer for me. Perfect It's what I needed to know. Thanks! –  Sukima Jan 11 '12 at 19:08

If you're using Tunnelblick, you might want to ask on the Tunnelblick discussion group Tunnelblick discussion group. If not, try the OpenVPN user's mailing list.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.