Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I currently connect to my work email (Exchange) using Outlook Web Access (OWA). I'd love to use Outlook to connect, preferably with IMAP but POP would be fine too. Does something need to be done at the Exchange server end to get this working?

thanks

Brian

share|improve this question
    
Hi guys, thanks for all the replies. Preferably I don't want to have to ask my systems administrator to change anything on the Exchange backend (because I know what the answer will be!). So prestomation's answer looks good. I'll give it a try. Cheers! –  TrojanName Jun 10 '09 at 21:12
    
Still not working guys. I'm not the administrator of Exchange and I don't want to ask him to make any changes, so most of the answers are not quite relevant to my problem. I understood that what I'm trying to achieve is possible using RPC over HTTP but am currently having issues with that. Can anyone else advise? –  TrojanName Jun 11 '09 at 10:30

5 Answers 5

up vote 0 down vote accepted

I believe it's possible for Outlook to connect to Exchange over the webmail interface(IE. RPC over HTTPS). This is how most mobile devices(iPhone/Windows Mobile) can connect to exchange.

http://www.msexchange.org/tutorials/outlookrpchttp.html

This would require no server sides changes, as it uses Webmail.

Disclaimer: I have not tried this.

What version of Outlook/Exchange are you running?

share|improve this answer
    
Well it sounded good, but I couldn't get past the "Check Names" after I entered the FQDN of the Exchange Server and my user name. This I don't understand, as I connect via OWA fine. By the way, I'm using Outlook 2007. I don't know which version of Exchange they are using. –  TrojanName Jun 10 '09 at 21:35
    
Sorry, I forgot to give the error message I was getting: "The action cannot be completed. The connection to Microsoft Exchange is unavailable. Outlook must be online or connected to complete this action." –  TrojanName Jun 10 '09 at 21:37
    
RPC over HTTP has to be enabled, if its not then you will get that error message. –  Sam Jun 11 '09 at 17:49
    
OK, thanks Sam. It seems I'm screwed then. Oh well, at least now I know. –  TrojanName Jun 11 '09 at 17:57

Let's say you're using Exchange Server 2003 and IMAP isn't enabled on your server. You'll have to follow this procedure:

Before you start

If you want to transmit your password and data over an encrypted connection (SSL), you must bind a Web site certificate to the IMAP4 service before it can establish a secure TLS connection with the IMAP4 client.

You can make either an online certificate request to an online Microsoft enterprise CA, or you can create a certificate request file and send the request to an offline CA (an enterprise CA, standalone CA or third party CA). The certificate is installed into the Exchange Server’s machine certificate store and bound to the IMAP4 service.

Enable the IMAP Service

You'll have to go to the Windows Services Panel and start the IMAP Service to enable "start automatically."

Configure IMAP on the Exchange Server

  1. Go into Exchange System Manager. Expand to
    Administrative Groups > GroupName > Servers > ServerName > Protocols > IMAP4
  2. Use the existing or create a new IMAP4 Virtual Server. New > IMAP4 Virtual Server and give it a name
  3. Assign IP to "All Unassigned"
  4. A new IMAP4 Server should be assigned in the right pane. Right click on it, and go into properties
  5. Leave General tab as is, unless you want to change the default TCP ports of 143 and SSL port of 993
  6. In "Access" tab, click on the "Authentication..." button and follow the onscreen instructions provided by the Wizard to complete the request. If don't you want to use SSL, you'll need to uncheck the "This server requires an encrypted connection" checkbox. But be aware that your password will be transmitted as clear text.

If you haven't configured the SMTP service, you'll have to do that in a similar way.

You'll also need to open the following TCP ports on your firewall to the front-end Exchange server (public interface):

  • IMAP4 (143)
  • SSL IMAP4 (993)
  • SMTP (25)

If you're running ISA Server in front of your Exchange Server, you'll have to enable IMAP4 and secure IMAP4 Server Publishing Rules. Exchange Services

The IMAP4 service is disabled by default on an Exchange 2003 Server. Set "Microsoft Exchange IMAP4" Service to "Automatic" and start the service. Also check, if the SMTP service is running and set to start auomatically.

share|improve this answer

first, make sure IMAP is enabled on your email account.

second, open IMAP port on firewall pointing back to your Exchange.

third, apply SSL to secure the traffic.

I think that's it. enjoy. However, personally, I prefer OWA from remote. You may also consider RPC-Over-Http as well.

share|improve this answer
    
Don't forget to start the IMAP server service if it's still in its stock state of "Disabled". –  Evan Anderson Jun 10 '09 at 18:07
    
+1 that was well said. –  Saif Khan Jun 10 '09 at 18:17
    
+1 well said. However if you are running Outlook as the client, rpc-over-https is the best way to do it as all Exchange services are available. We use rpc-over-https everywhere, including internal workstations. –  David Mackintosh Jun 10 '09 at 18:29

You just need to enable POP or IMAP on Exchange. Go into services.msc and enable the appropriate services.

Technet instructions for Exchange 2007: http://technet.microsoft.com/en-us/library/bb124489.aspx

or Exchange 2003: http://technet.microsoft.com/en-us/library/aa996393(EXCHG.65).aspx

share|improve this answer

Are you an end user or are you in charge of administering the server? What version of Exchange are you running? Here are a couple links to get you started:

Exchange 2003

Exchange 2007

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.