Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am trying to allow more than the default of 2 concurrent remote connections to a server running Windows Server 2003.

Background:

I went to "Start" => "Administration Tools" => "Terminal Services Configuration"

I opened up the "Properties" of "RDP-tcp" in the connections tree and selected the "Network Adapter" tab:

  • "Unlimited connections" is grayed out
  • In "Maximum connections" I can change the value to "1" using the arrows
  • However, I can not increase the value above "2" with the arrows
  • I typed in 4 and clicked apply. But the value did not stick.

Is this a licensing issue? If not, how do I allow more than 2 remote session?

share|improve this question
    
Also worth mentioning that to remote desktop into the server, you do NOT need Terminal Services installed, you just need to enable Remote Connections in the System Properties (like you would in XP). –  Mark Henderson Jun 10 '09 at 23:08

5 Answers 5

up vote 17 down vote accepted

This is a licensing issue. W/o purchasing Terminal Services CALs you're limited just as you've seen to two (2) RDP connections.

(You can sort of cheat and get one more session, BTW, by using the "/admin" or "/console" switch on the Terminal Services client.)

share|improve this answer
2  
To expand on this, at the moment the server is probably configured to allow terminal services connections for administrative use, which isn't the same as being a terminal server. As Evan says, you need to address licences and also IIRC you have to install the terminal server role to serve end users. –  RobM Jun 10 '09 at 18:08
1  
One more thing, running with the Remote Administration mode as Theo is doing means the users are full admins, whereas Terminal Server allows less powerful users. –  Matt Jun 10 '09 at 20:29
    
@Matt, not true at all. You can log in to a remote desktop session even if you are not a local administrator, you just need to be in the "Remote Desktop Users" group. The licensing mode of the terminal server doesn't affect your user rights in any way. –  Massimo Feb 22 '12 at 21:06

You get 2 remote administration connections and a console connection, and that's it. There is no way to override this limit (that I've ever seen at least).

If you want more than the 2 connections, you need to get a license for Terminal Service CALs. Then you can do as many as you have licensed.

share|improve this answer
    
I can' even get 2 RD sessions to windows 2008 server R2. I'm using the same username\password for both sessions, is this is why it isn't working ? –  Muhammad Gelbana Sep 3 '13 at 11:57

why do you need more than 2 ? If it's because people doesn't logoff, you can set TS to logoff people when they are disconnected for too long & co, even through GPO is many servers.

Going further than 2 mean license and change the server to a TS application server, why may not be what you want.

Else you can also try a TS challenger: go-global from graphon. It doesn't use the Terminal server layer.

share|improve this answer

It looks like you want to use the server as remote desktop server for allowing people to using the applications on the server rather than just managing it. If so, you need to turn on Terminal Service from Add/Remove program first. And before you allow people to log in, you need to purchase and set up TS License server.

share|improve this answer

In administrator tools the terminal services configuration option has the power to do this. Open this application and expand the connection. Right click on RDP - TCP, and then open properties of that connection. On the network adaptor tab click on unlimited connection. Then apply and OK. Open Run and type gpupdate and press enter.

That's all.

share|improve this answer

protected by sysadmin1138 Oct 5 '11 at 20:50

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?