Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a scheduled task that needs to run as a service account. The service account's password resets every 100 days, so I need to update the password for the scheduled task.

I cannot figure out how to do this. When I select "Change User or Group" in the scheduled tasks' properties I get no prompt to update the password.

This scheduled task will be deployed on Windows Server 2008 R2 and Windows 7.

share|improve this question
up vote 8 down vote accepted

You will be prompted for the account password when you click the Ok button to confirm the task property changes. Click the "Change user or Group" button and retype your service account name and click Ok. Then click Ok on the task properties and you should be prompted to enter the service account's password. Note that you have to choose "Run whether user is logged on or not" in the Security Options section right in order to set the password. Otherwise it'll use the authentication token of the logged in user at the time the event fires.

share|improve this answer

Check the box "Do not store password." Accept the changes to the task. Edit the task properties again and uncheck the box. You will be prompted for the new password.

share|improve this answer

protected by voretaq7 Aug 14 '13 at 15:47

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.