Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Our network computers are all connected to a domain, and I can see them if I search the active directory (I can click 'search active directory' and then select 'computers' and then Find Now, and all of the computers will appear). However, the computers are not listed in the network browser on any of our computers (Win XP, Win7, Linux, etc) which are connected to the domain.

DC is running Windows Server 2008 (Windows Server Standard) with a configured DNS and DHCP server. All of the IPs on our local network are static IPs, although I can't see how that would make a difference. I can still connect to computers on the network via \\computer_name, but I cannot browse them in 'network' or in 'my network places'.

The computer browser service is not started on the DC, but I tried starting that and it had no effect. DC currently has the firewall configured as 'off' to try to debug this problem.

Thanks in advance

share|improve this question

1 Answer 1

What you need to do is this:

Windows XP: http://www.intelliadmin.com/index.php/2006/01/enable-file-and-printer-sharing-on-xp-sp2/

Windows Vista: http://windows.microsoft.com/en-US/windows-vista/Enable-or-disable-network-discovery

Windows 7: http://windows.microsoft.com/en-US/windows7/Enable-or-disable-network-discovery

That's how you enable it on all of your clients. Afterwards, you should be able to see all clients from all clients.

share|improve this answer
    
Network discovery is enabled on all computers. It's probably worth mentioning that this all worked on our previous domain controller. I would like to assume that this a configuration problem with our new DC. –  Giawa Feb 14 '11 at 22:22
    
Is it enabled on the DC as well? Just want to cover all my bases. –  JohnThePro Feb 14 '11 at 22:26
    
Hi John - Yes. It was originally set to 'Custom', but I've changed it to 'On' with no effect. The custom setting was due to the windows firewall configuration. I've restored the default firewall settings and still cannot browse the domain computers. –  Giawa Feb 14 '11 at 22:40
    
It takes time to build the network browse list. If you've made sure that Network Discovery is enabled on the server then let it sit for awhile. In the pre-Network Discovery days it could take up to 45 minutes to build the browse list. –  joeqwerty Feb 14 '11 at 22:50

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.