Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am trying to install mod_wsgi on my VPS, but it won't work. This is what I am doing:

wget http://modwsgi.googlecode.com/files/mod_wsgi-2.5.tar.gz
tar xzvf mod_wsgi-2.5.tar.gz
cd mod_wsgi-2.5

./configure --with-python=/opt/python2.5/bin/python

After I run the above command, I get this error:

checking for apxs2... no
checking for apxs... no
checking Apache version... ./configure: line 1298: apxs: command not found
./configure: line 1298: apxs: command not found
./configure: line 1299: /: is a directory

./configure: line 1461: apxs: command not found
configure: creating ./config.status
config.status: creating Makefile
config.status: error: cannot find input file: Makefile.in

Through some research I've discovered that I need to modify my command:

./configure --with-apxs=/usr/local/apache/bin/apxs \
--with-python=/usr/local/bin/python

But, /usr/local/apache/ doesn't exist, or so that's what it is telling me. If it doesn't exist, how do I create it with all the files needed, or if apache is located elsewhere on my VPS where would it be located?

I'd also like to mention that I ran a command to install apache before this entire deal:

yum install httpd

so I assumed that was all I needed but apparently not (I am very new at all this server administration stuff so please be gentle)

EDIT: This is the tutorial that I have been using to get this all set up: http://binarysushi.com/blog/2009/aug/19/CentOS-5-3-python-2-5-virtualevn-mod-wsgi-and-mod-rpaf/

I got stuck at the heading "Installing mod_wsgi"

Thanks for any help!

share|improve this question
add comment

1 Answer

mod_wsgi is in EPEL. Once configured, you will be able to install it via yum as well.

Edit: Direct link to instructions on adding the EPEL repo.

share|improve this answer
    
The reason I am doing this entire tutorial is because when I tried 'yum install mod_wsgi' it said that there was no package called mod_wsgi...I looked in the EPEL file list and there is 49 files that have mod_wsgi in their title... –  jasonaburton Feb 15 '11 at 23:40
    
I have no idea how to install it..any suggestions? –  jasonaburton Feb 15 '11 at 23:41
    
... Follow the link that says "How to use EPEL" on the page? –  Ignacio Vazquez-Abrams Feb 16 '11 at 2:46
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.