Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

My Server has 4 IP addresses.

(IPs are for example only) 1.2.3.4 1.2.3.5 1.2.3.6 1.2.3.7

Under IIS, I have a Virtual SMTP Server on 1.2.3.5, on port 25. The virtual server installed there at the start on 1.2.3.4 is disabled.

1.2.3.5 is mapped to my hostname, mailhost.mydomain.com and the rDNS PTR is configured for that as well.

When I send an Email using mailhost.mydomain.com - it works, but it shows up in headers that the email is coming from 1.2.3.4 with no reference to 1.2.3.5 at all.

Any ideas?

Cheers

share|improve this question
    
Are these IPs all on the same subnet? Different NICs or aliases? What interface has the default gateway? –  gravyface Feb 15 '11 at 16:46

1 Answer 1

The SMTP service listens to port 25 on all unassigned IP addresses even if you specify a specific IP address for the default virtual server. You need to disable the Microsoft Internet Information Services (IIS) socket pooling feature (DisableSocketPooling). This property is not exposed in ADSI for SMTP.

http://support.microsoft.com/kb/281760

  1. Install and run MetaEdit on the server.
  2. Expand LM and SmtpSvc.
  3. Right-click SmtpSvc, click New, and then click DWORD.
  4. In the Id list, click DisableSocketPooling. The field to the right should now read 1029. If DisableSocketPooling is not in the list, click (Other), and then type 1029 in the box.
  5. In the Data field, type 1.
  6. Click to select the Inherit attribute.
  7. Restart the Simple Mail Transport Protocol (SMTP) service.

Hope this helps.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.