Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I want to virtualize a physical machine and I used Disk2Vhd to convert the Hard drive to a .vhd file.

My issue is that when I attach this vhd in Hyper-V, and try to install

"Integration Services", I get the message "HAL Upgrade Required",

and after sometime,

"You must restart your system before Hyper-V Integration services can be installed. Do you want to restart now"

The problem is that these steps get repeated again and again and I am never able to install the Integration services.

Addition Info:

Server: Windows 2008 R2
Guest Machine: Windows 2003 Server with SP2

Any suggestions??


share|improve this question
hmm the hal upgrade message is normal as is the integration component message. I'd look at the hyper-v logs under the integration components and see what its saying there! – tony roth Feb 15 '11 at 18:28
Same thing happened to me. Did you modify the multi-boot (boot.ini?) file to remove the other "disk2vhd" boot option or somehow change the default boot? – Warren P Oct 18 '12 at 15:45
I changed the default order of operating systems to always boot from the correct location- I did not remove the other boot option – user67714 Oct 18 '12 at 17:07
up vote 9 down vote accepted

After going through forums.. finally found the solution. (the link is here )

When you start the VM under Hyper-V, you get a Multi-Boot option,

Disk2Vhd Windows Server 2003 Standard
Windows Server 2003 Standard

You must boot the system with Windows Server 2003 Standard and not with Disk2Vhd one.. Thanks to the guy who found out!!! - I wasted almost a week on this, glad that it's finally working

share|improve this answer
GREAT!!! I've been having this problem on a VM (which didn't P2V myself) for a while, and completely overlooked the multiboot issue... would never have guessed it! – Massimo Mar 31 '12 at 12:02

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.