Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We have some users who work remotely and they access their e-mail in Outlook 2003 using RPC over HTTP. We just hired another sales guy and the laptop we bought for him came with Office 2010, so I decided to give it a whirl. I set it up the same as I normally would for Outlook 2003 and sent him on his merry way. Now he's back home several thousand miles away and can't get to his e-mail. He is able to access his e-mail using Outlook Web Access.

Searching around on Google, lots of people were pointing to https://testexchangeconnectivity.com/ so I gave that a try. Most of the steps are successful, but it fails on "Attempting to ping RPC endpoint 6001 (Exchange Information Store)". I'd like to fix this, though I suspect fixing it may not automatically fix the outlook 2010 issue.

I checked the registry setting for ValidPorts, and it's configured correctly. I have ports 80, 443, and 6001-6004 being forwarded on the router to the Exchange server.

If Outlook 2010 just won't work with Exchange 2003, I can accept that, though trying to rectify it will be interesting because I don't expect this guy will be back in the office for a long time. Has anybody got Outlook 2010 working with Exchange 2003 using RPC over HTTP?

If you have a solution, or something you want me to do to help investigate the problem, please give specific steps. Exchange Server is slightly outside my area of expertise.

share|improve this question
    
I do not know the answer to your issue but I am working with Outlook 2010 RPC/HTTP on exchange 2003. –  pablo Feb 15 '11 at 20:26
add comment

3 Answers

up vote 1 down vote accepted

The Office 2010 user showed up in my office today, so I downgraded him to Outlook 2003.

share|improve this answer
add comment

Outlook 2010 works with Exchange 2003, that's 100% true. I have at least 3 clients environments working with this config. Please note, except ports 80 and 443 you don't need to open ANYTHING in the firewall. I can give you some advice on the matter and help in configuring the settings correctly. Where are you located?

share|improve this answer
    
Send me an email to meskalit@gmail.com with your details, I'll contact you this evening to try to schedule a time to inspect the environment. –  Vick Vega Feb 15 '11 at 21:45
4  
For the benefit of the community, I'd prefer if you could explain on here what I should be checking. –  Scott Feb 17 '11 at 20:13
add comment

I had the exact same problem, and finally solved it after a day and a half of investigation. The problem IS the ValidPorts registry key. You need to make sure it references the precise domain name that the mobile Outlook client uses to access it, it's very easy to overlook since the key is already populated with other names. Take a look at my answer and update accordingly.

If you pass the testexchangeconnectivity.com test, I'd appreciate stealing that green checkmark from you ;)

share|improve this answer
    
I double-checked ValidPorts and the port numbers are set up for both the internal AND external host names, so I don't think that's the solution to my problem. –  Scott Nov 10 '11 at 17:17
    
Triple-check it. It took me about 5 times before I finally noticed what the problem was. Check to make sure the RPC proxy is configured correctly also. The testexchangeconnectivity.com results that you had indicate that the server can't proxy requests from the front-end to the back-end services, so the problem lies somewhere there. –  Bigbio2002 Nov 10 '11 at 19:20
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.