Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Please bear with me as I'm not a networking person by trade.

Our current configuration at work includes two Windows Servers serving as DHCP/Active Directory servers (if that makes sense) -- one replicating from the other. On both machines, the DNS resolution is set up as:

DNS Server List

That is:

  1. Internal Windows Box
  2. External Provider
  3. External Prover
  4. Internal Windows Box

Assuming our domain is, we maintain the website on a hosted VPS with it's own IP address.

The problem is that even though is an internal server and is defined in DNS on the Primary Windows machine, when I ping bar or even it resolves to the hosted IP address instead of the 10.* address.

I tried taking both of the Public IP addresses out of the DHCP scope, and that seemed to work, but it completely slowed down access to any external sites, so that wasn't acceptable. I also tried adding the two Windows machine as the DNS servers on my desktop. That too worked, but I'd rather not have everything enter their DNS servers, as the above setup should theoretically be working.

Is there anything I could check to see why pinging isn't resolving to the DNS entry on the Windows machines?

Here's a summary of the ping results, if they help:

Pinging from servers with static IP resolves with correct IP address

Pinging from linux machines not joined to the domain resolves with correct IP address

Pinging from user's desktop machines, joined to the domain, but dynamic IP resolves with incorrect IP address

This is driving me crazy!

share|improve this question
Honestly, I can't figure out what you're trying to achieve or how you've got things configured. Why do you have the Verizon ip addresses in a DHCP pool? Why do you have your servers acquiring their ip addresses via DHCP instead of having them statically assigned? – joeqwerty Feb 16 '11 at 15:17
Servers are getting their IP addresses statically assigned. The user's machines are getting them from DHCP. Interesting, from the servers, pinging does resolve correctly -- it's from the user's machines that things get strange. – jerhinesmith Feb 16 '11 at 15:19
So is your problem with DNS or DHCP? – joeqwerty Feb 16 '11 at 15:20
DNS, sorry, I updated the question. According to someone that was helping me, the problem was that DHCP scope looked like it wasn't getting properly applied, so that's what lead me down that line of verbiage. – jerhinesmith Feb 16 '11 at 15:22
up vote 1 down vote accepted

Your DHCP server should be handing out the IP addresses of your DCs as the DNS servers. Your DNS servers should have an entry for that points to the internal IP address. After you do this, renew your IP address and everything should work.

share|improve this answer
That's the problem. The internal DNS servers do have an entry for For some reason it's skipping the DCs though and going right out to the public DNS servers. – jerhinesmith Feb 16 '11 at 15:27
When I do nslookup on, I get the right (internal) IP. When I ping, I get the wrong (external) IP. – jerhinesmith Feb 16 '11 at 15:28
@jerhinesmith - You should NEVER configure external DNS servers when you have active directory setup. Only use AD DNS servers. Don't even put the public DNS servers in there as a backup. – Jason Berg Feb 16 '11 at 15:44
Sites resolve to the outside world through forwarders or root hints. If you go into the properties of your DNS servers, you can setup forwarders there. Anything that doesn't hit on the internal DNS records would be forwarded on. The other option is root hints. That's a slower process for small shops. So configure your forwarders! – Jason Berg Feb 16 '11 at 15:49
@jerhinesmith - within DNS manager, right click on the name of the server and go down to properties. The interface tab is where you configure binding. The forwarders tab is where you configure forwarders. – Jason Berg Feb 16 '11 at 15:50

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.