Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I install and configure l7-filter:

sudo apt-get install l7-filter-userspace l7-protocols
sudo cp /usr/share/doc/l7-filter-userspace/examples/sample-l7-filter.conf /etc/l7-filter.conf
sudo l7-filter -f /etc/l7-filter.conf -q 2 -v
sudo iptables -t mangle -A PREROUTING -j NFQUEUE --queue-num 2
sudo iptables -t mangle -A OUTPUT -j NFQUEUE --queue-num 2 

l7-filter loads all protocol and doesn't give error:

Got packet, had no ct:  udp      17 src=192.168.1.1 dst=8.8.8.8
sport=45659 dport=53
Got packet, had no ct:  udp      17 src=192.168.1.1 dst=8.8.8.8
sport=34234 dport=53
share|improve this question
    
What happened? What did you expect to happen? Does the "sample-l7-filter.conf" actually do anything? If there were no errors how do you know it didn't work? –  DerfK Feb 16 '11 at 18:01
    
l7-filter does not set markers –  bindbn Feb 16 '11 at 18:06
add comment

1 Answer 1

up vote 1 down vote accepted

Try load ip_conntrack_netlink and nf_conntrack_ipv4 modules:

sudo modprobe ip_conntrack_netlink
sudo modprobe nf_conntrack_ipv4
share|improve this answer
    
How did you find them? –  bindbn Feb 16 '11 at 18:08
    
@bindbn In Ubuntu 10.10, when run l7-filter I get the WARNING –  ooshro Feb 16 '11 at 18:12
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.