Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am working on a website running Sitecore 6.3.1 on a Windows Server 2008 R2 instance.

Everything was working beautifully until I copied some static files (CSS, JS, images) from a ZIP archive provided by one of our frontend developers into C:\Inetpub\wwwroot\(website name)\Website\static.

Now, any time I try to access any of those static files (e.g., http://localhost/static/css/main.css), I get a 401.3 error (according to C:\inetpub\logs\LogFiles\W3SVC2\u_ex110216.log).

The Sitecore application itself is working just fine, and the static files were perfectly accessible until I replaced them with the updated files.

According to every resource I could find on the subject, a 401.3 error indicates that the ACL for the requested resource is not permitting access to the IIS user account.

  • I looked at the ACL for a file that is currently working (e.g., C:\Inetpub\wwwroot\(website name)\Website\default.css), and it appears to be identical to that of the static files that are inaccessible.

  • I checked the application pool settings for the Sitecore site, and the anonymous user is "IUSR". Following the instructions in this thread, I gave the IUSR account read and execute permissions for the C:\Inetpub\wwwroot\(website name)\Website\static directory and recursively applied it to all subfolders and files in that directory. No dice.

  • Based on the suggestions offered in this thread, I tried removing the static directory entirely and recreating it and its subdirectories by hand so that they inherit permissions from the parent Website directory. However, the problem persisted.

What else can I try to resolve these 401.3 errors?

share|improve this question
add comment

3 Answers 3

up vote 2 down vote accepted

I discovered what was causing the problem:

It turns out that the "Encrypt contents to secure data" attribute was set for each of the files.

I accessed the properties for each file and unchecked that checkbox (right-click -> Properties -> Advanced... (next to Attributes) -> uncheck Encrypt contents to secure data), and everything is back to normal.

share|improve this answer
add comment

I had a similar issue today, and what fixed it for me was your second point about giving the IUSR account read and modify permissions on the files and directories (it wasn't just the static files that I was dealing with)

share|improve this answer
add comment

Check that the Application Pool Identity has permissions on the site and for network services.

share|improve this answer
2  
How? A few steps will help a lot. –  user30804 Jul 3 '11 at 18:19
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.