Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have got a laptop which is configured to have the user profile in a network drive. This is causing me a lot of headaches since the connectivity to my company is very slow. I want to relocate the profile of my user into a local directory. How do I do that?

Those are the settings at the moment:

C:\>set HOME
HOMEDRIVE=P:
HOMEPATH=\
HOMESHARE=\\SOMESERVER\_myuser$

The drive P is a network drive mapped to HOMESHARE.

I can't find where windows is setting those environment variables, not even in the registry.

The laptop is running Windows XP.

share|improve this question

closed as off topic by Iain, Chris S, Scott Pack, John Gardeniers, Doug Luxem Feb 16 '11 at 21:33

Questions on Server Fault are expected to relate to professional server, networking, or related infrastructure administration within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

    
So this laptop is part of a business network, and you are the SA? –  Chris S Feb 16 '11 at 20:56
    
No this is a laptop that has been assigned to me for doing software development. I'm not a SA, but I have admin privileges. I am trying to make it work without being a pain, since everytime the profile drive is accessed the laptop becomes slow or freezes, and login/logout takes hours while doing the synchronization of the roaming profile. I managed to disable most of the synchronization stuff, but I'd really like to complete remove the dependency on the remote profile drive, to solve the issue at the root. –  Luigi R. Viggiano Feb 16 '11 at 20:59
    
Have you talked to your admin, who should be able to sort this out for you? –  John Gardeniers Feb 16 '11 at 21:14
    
No, I've not done that. I usually try to solve the problems by myself, with the help of internet. In my experience asking something like this could produce the result to get informed that what I am trying to do is not allowed. So, better not to ask. And in case I can say "oh, I didn't know that" :-) –  Luigi R. Viggiano Feb 16 '11 at 21:16

1 Answer 1

up vote 1 down vote accepted

From the comments it sounds like you are trying to override what the sysadmins have setup for you. This could likely generate some decent backlash against you as the policies are likely there for a reason.

I would recommend:

Talk to the sys admins of your setup. Don't call them and tell them you need it removed, tell them what is wrong and ask them if there is anything they can do to change this. Remember in some instances it may not be in their power to change this, but it won't hurt to ask for help.

Be knowledgeable about your setup. While you indicate the connection to the corporate network is slow, is it your home network or the corporate network. In a lot of instances that I see the home network is fine but there is a misconfiguration related to the vpn connectivity that causes the connections to be slower than expected. Overall maybe it is just an issue with the laptop they provided you and not with the network at all. Try and explain as calmly as you can about what it you need to do exactly. Remember the policies are there for a reason.

Be open to pushback on policies. A lot of sysadmins default responses will be no, be open to this and keep try and be polite about the issues you have, it will get you a lot farther than being forceful. Try and understand why the policies are in place, even if they aren't the best for your setup.

Ask if you can use your own equipment. Maybe you do not have a home laptop, or maybe they require you to use a company pc to connect. Ask IT if they can check your home computer and allow you to use it to connect remotely.

The settings you have in place are likely controlled centrally and cannot be easily overridden. Even if you were to change the settings it is likely they would be overridden next time you logged in.

After all that here is how to override it. This is not recommended as unless you have a really BOFH IT department if you are calm and try and work with them on your issues they will help you if they can. Keep in mind sometimes people's hands are tied with red tape.

Create a new local account and login with it. Make it a local administrator on the machine and login as that account, authenticate where needed with your work credentials. If that doesn't work unjoin the computer from the domain. This could cause IT a lot of headache and possibly make your laptop unusable, but may get you what you are after.

share|improve this answer
    
Thanks, for the hints. I understand your point, and I considered them. The local account works, I already tried that, but I am trying to fix the domain account. Probably you are right that the setting is managed centrally since I've done a lot of searches and I didn't find an answer to this question. BTW, I am quite sure that there should be a way to fix this setting locally and those variable are likely assigned in some place during the login process. I made a disk backup already, so I am ok to experiment and even to crash the operating system. Connecting my pc to business net is not allowed. –  Luigi R. Viggiano Feb 16 '11 at 21:28

Not the answer you're looking for? Browse other questions tagged or ask your own question.