Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Trying to get Apache2 working on Mac OS X 10.6.6. I get the following crash.

Process:         httpd [27434]
Path:            /usr/sbin/httpd
Identifier:      httpd
Version:         ??? (???)
Code Type:       X86-64 (Native)
Parent Process:  launchd [1]

Date/Time:       2011-02-16 20:56:12.971 +0000
OS Version:      Mac OS X 10.6.6 (10J567)
Report Version:  6

Exception Type:  EXC_BREAKPOINT (SIGTRAP)
Exception Codes: 0x0000000000000002, 0x0000000000000000
Crashed Thread:  0

Dyld Error Message:
  Library not loaded: /usr/lib/libapr-1.0.2.7.dylib
  Referenced from: /usr/sbin/httpd
  Reason: image not found

Binary Images:
    0x7fff5fc00000 -     0x7fff5fc3bdef  dyld 132.1 (???) <486E6C61-1197-CC7C-2197-82CE505102D7> /usr/lib/dyld

I have checked and have libapr but its 1.0.3.9

Does anyone know of a work around or fix for this problem?

After installing apache2 I still got the same error.

aran:lib aran$ sudo httpd -k
dyld: Library not loaded: /usr/lib/libapr-1.0.2.7.dylib
  Referenced from: /usr/sbin/httpd
  Reason: image not found
Trace/BPT trap
share|improve this question

2 Answers 2

Is libapr present?

If not, try installing it:

sudo install_name_tool -change /usr/lib/libapr-1.0.dylib /usr/lib/libapr-1.0.2.7.dylib /usr/sbin/httpd

If that does not work, you might want to try this:

http://diymacserver.com/installing-apache/compiling-apache-in-64-bits-mode-on-snow-leopard/

share|improve this answer
    
Still no luck! :-( I get the following: aran:lib aran$ sudo httpd -k dyld: Library not loaded: /usr/lib/libapr-1.0.2.7.dylib Referenced from: /usr/sbin/httpd Reason: image not found Trace/BPT trap –  Aran Feb 16 '11 at 22:35

My work around for this error was to copy libapr-1.0.3.8.dylib to libapr-1.0.2.7.dylib

I know its not actually 1.0.2.7 and would be probably better to make a symbolic link but that had failed when ever I tried it failed.

For people needing to fix this easiest method I found was too run the following command from within the /usr/lib folder.

cp libapr-1.0.3.8.dylib libapr-1.0.2.7.dylib
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.