Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Firstly my main goal is to try and get FTP files recursively in Centos. However the actual FTP login contains an @ which ruins the syntax. Is there some way to place the username in "double quotes" or some such equivalent such that I can use @in the username?

share|improve this question
    
are you running ftp via command line? –  pablo Feb 16 '11 at 21:24

3 Answers 3

If you use wget's --user=wh@tever and --password=bl@h options rather than the user:pass@host syntax, it should work fine.

share|improve this answer

Have you tried replacing the @ by

@

?

share|improve this answer
    
Doesn't seem to work...you mean something like (assuming login of me@domain.com) wget -r me@domain.com:password@ftp.mydomain.com –  deltanovember Feb 16 '11 at 21:59

what about replacing @ with %40

since it is posted by http special chars should be urlencoded.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.