Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

We have two network switches, a POE switch (SwitchA) to power our phones / users computers and a non-POE switch (SwitchB for the rest network.)

Each switch is setup to do port mirroring to support our VoIP recording system. SwitchA does port mirroring on specific ports if we need to record a user. SwitchB mirrors one port to monitor our work at home users (Internet comes in from managed router, to switch, back out to our firewall.) These two port mirroring setups feed into one vmware vSphere 4.1 server, it has four total physical cards. The other two NICs feed into an unmanaged switch for connecting to the rest of the network.

Once into the vSphere server all network ports go into a vSwitch, and then one of the servers (Windows 2008 R2) sniffs them out and does its thing.

Everything is working fine and dandy from SwitchB. But on SwitchA we only receive one side of the VoIP packets (going out to the phone, nothing coming in from the phone).

Troubleshooting steps I have taken so far:

  • I hooked up my laptop to the monitor port on SwitchB and I see both sides of the packets.
  • I swapped which network interface is plugged into the monitor port on SwitchA.

Because everything feeds into one vSwitch / vNetwork and both sides of the conversation arrive just fine from SwitchB I believe everything is configured correctly on the vSphere server/guest.

What could be causing one way packets to arrive on my guest machine from only one interface, but not the other? Could a bad cable be causing the problems from SwitchB?

Edit:

  • I also enabled the monitor port on my switch to be in Trunk mode, instead of Access Mode.
  • I set the vlanID to All(4095) on the VM Network.
  • I turned Promiscuous mode = Accept for the vSwitch. (I had it off so my VoIP recording server didn't see all of the vSwitch traffic.)

Can a vSwitch have two vlanIDs? Could I set the vSwitch to have both 1 and 50 associated with it? It seems that because there is a drop down for either None (0) or All (4095) those are my options.

share|improve this question
    
A network diagram may help get some answers. There is a lot going on in this question... –  JakeRobinson Feb 22 '11 at 2:29

1 Answer 1

up vote 1 down vote accepted

To answer my own question it was a real simple change to my NIC driver on the guest machine.vNic Driver Configuration

As you see above I changed the "Priority & VLAN" property from "Priority & VLAN Enabled" to "Priority Enabled". I also set the vNetwork to be a trunk as shown below. vSwitch Trunk Config vSwitch Properties vNetwork Properties

share|improve this answer
    
Thank you so much! This post just solved an issue that has hounded me for days, specifically the situation on your switch A with port mirroring to record phone calls. In the end for me it was exclusively the VLAN = ALL (4095) on the virtual port group and the promiscuous mode on the vSwitch. The NIC change in the VM and the mirrored port being a TRUNK port weren't necessary. -Adam –  Adam Sep 17 at 21:20

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.