Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

When attempting to add a normal A record (which has so far always worked), the Microsoft dnsmgmt app in MMC is returning a successful creation message "The host record oneworld.mydomain.com was successfully created". However, after refreshing the zone, it displays a folder icon next to "oneworld" indicating a sub domain, i.e. it is not the A record dnsmgmt said it created successfully.

This is really strange behavior that has never happened previously. We have tried this on two separate PCs and remote consoled into the primary DNS server and tried adding the same A record with the same results.

Any help is appreciated.

share|improve this question

4 Answers 4

I would look in %windir%\system32\dns and find the zone file that you are changing and see if the formatting looks out of place. My guess is that something is missing a root designator (dot and the end of an address).

share|improve this answer
1  
If it's AD integrated DNS you won't find it there, but you'll have to go into your configuration partition using adsiedit.msc or similar. –  Darth Satan Jun 10 '09 at 22:08
    
I stand corrected mh. –  Saif Khan Jun 10 '09 at 23:00

Given that you provided an example of oneworld.mydomain.com, this probably isn't your issue but I've had people ask me about similar behavior in the past because they added an additional subdomain in the A record they created. Say, for instance, you add an A record for server1.oneworld.mydomain.com to the domain mydomain.com. DNS notices that you added a subdomain there (oneworld) and creates a new subfolder for it and then puts the A record in there. This is to be expected and indeed appreciated as Microsoft has just saved you a few extra clicks. Again, this is probably not your issue but just in case...

share|improve this answer

When you do a nslookup for oneworld.mydomain.com does it return the IP you associated it with?

On the other note, is DNS zone has very large number of records? if yes, it might be just the GUI glitch or something not able to handle large number of objects.

share|improve this answer

I observed the same thing with a PTR record. In the actual zone file, the PTR record is identical to all the rest; but in the GUI, it displays as a separate folder, with a single record: "same as parent folder"-PTR-system name. The DNS works, and as I said the internal representation is correct, so I'll just chalk it up as one of those charming little MSWin quirks that somebody somewhere who is not me must love.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.