Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Our gentoo server has been left in inconsistent state. I don't know what have been done wrong previously, but now I need to fix the system somehow.
I've tried to do revdep-rebuild, but it has failed:

...
x11-libs/gksu:0
x11-libs/gtk+:2
x11-libs/gtkglarea:2
x11-libs/libgksu:2
x11-libs/libsvg-cairo:0
x11-libs/qt-gui:4
..........

  • IMPORTANT: 12 news items need reading for repository 'gentoo'.
  • Use eselect news to read news items.

Calculating dependencies... done!

emerge: there are no ebuilds to satisfy "gnome-base/gswitchit-plugins:0".

emerge: searching for similar names...
emerge: Maybe you meant any of these: gnome-base/gswitchit-plugins, gnome-extra/gswitchit-plugins, gnome-base/nautilus?

  • IMPORTANT: 12 news items need reading for repository 'gentoo'.
  • Use eselect news to read news items.

  • revdep-rebuild failed to emerge all packages.

  • you have the following choices:
    • If emerge failed during the build, fix the problems and re-run revdep-rebuild.
    • Use /etc/portage/package.keywords to unmask a newer version of the package.
  • (and remove 5_order.rr to be evaluated again)
    • Modify the above emerge command and run it manually.
    • Compile or unmerge unsatisfied packages manually,
  • remove temporary files, and try again.
  • (you can edit package/ebuild list first)
  • To remove temporary files, please run:
  • rm /var/cache/revdep-rebuild/*.rr

I've tried to remove one of the mentioned packages:

harley ~ # emerge -C gswitchit-plugins
Wrong gcc version = echo -C gswitchit-plugins
harley ~ #

I don't see any problems with the gcc, but emerge isn't working:

harley ~ # gcc --version
gcc (Gentoo 4.5.2 p1.0, pie-0.4.5) 4.5.2
Copyright (C) 2010 Free Software Foundation, Inc.
This is free software; see the source for copying conditions. There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

harley ~ # gcc-config -l
[1] i686-pc-linux-gnu-3.3.6
[2] i686-pc-linux-gnu-3.4.6
[3] i686-pc-linux-gnu-3.4.6-hardened
[4] i686-pc-linux-gnu-3.4.6-hardenednopie
[5] i686-pc-linux-gnu-3.4.6-hardenednopiessp
[6] i686-pc-linux-gnu-3.4.6-hardenednossp
[7] i686-pc-linux-gnu-4.1.2
[8] i686-pc-linux-gnu-4.5.2 *
harley ~ # emerge --help
Wrong gcc version = echo --help
harley ~ # which emerge
/root/bin/emerge
harley ~ # emerge
Wrong gcc version = echo
harley ~ # emerge fdslkgj
Wrong gcc version = echo fdslkgj
harley ~ #

How can I fix emerge?

share|improve this question

1 Answer 1

# cat /root/bin/emerge  
#!/bin/sh   echo "Wrong gcc version = echo $@"   gcc -v 2>&1 | grep "gcc
version 4.3.1" || exit 1  
/usr/bin/emerge $@

Looks like it was necessary to have gcc of version 4.3.1 selected.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.