Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Using the latest version of Plesk (on Windows Server 2008 R2), when I create a new sub-domain the file permissions are always wrong. Plus they always seem to reset themselves. I assume Plesk is doing some security housekeeping but what am I doing wrong?

Take a sub-domain example:

  • I create the sub-domain so that it will be isolated in its own folder structure
  • Copy in my application files (At this stage the application will not run as the permissions are wrong, I need to give permissions to the IWPD_* user)
  • In plesk I often try to go into the File Manager and add this account and give them full permissions. (This often isn't enough the applicationw may still not run)
  • The final and most important step is going to the actual folders themselves, going to Properties > Security and then manually adding the required account(s).

As soon as the final step is done the application will run perfectly, until perhaps plesk does it's security housekeeping routine and wipes the permissions.

What I want to happen is that the permissions are automatically inherited by any files and folders that I are children of the httpdocs directory.

I have setup a build server that will deposit a compiled build of the application everytime there is a commit to the repository. The end result is dumped into a plesk dub-domain httpdocs directory. I want to make sure that any files / folders that end up there will have the necessary permissions and the application will run without manually having to set them.

Many thanks for any help clearing this up for me!

share|improve this question

1 Answer 1

Plesk is a nightmare for hosting domains in it's normal way. I eventually found the DNS only hosting option which means you can use plesk for the DNS creating sub-domains etc.. and then just use IIS websites as you would on your dev pc..

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.