Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a host (Ubuntu Linux) with VirtualBox on which is installed client (Windows XP). I set bridge connection for them.

Host has IP and client

On client I've installed WAMP server and on host I can access it by simply call

When I connect on client to the Cisco VPN (need access to database over VPN) I cannot access that server from host.

What should I do to make it work ?

share|improve this question
up vote 0 down vote accepted

Which Cisco VPN?

If it is the Cisco AnyConnect VPN Client, then you should enable LAN access in it.

You might not be able to get more than 1 IP address from the VPN though. If that is the case you should use NAT mode, then your virtual machine will have the same network access as your host.

share|improve this answer
It's not AnyConnect, but I can enable LAN - however it not helps. When I tried to set it as NAT, I forwarded ports like posted here… - it works until I connect to vpn. – hsz Feb 17 '11 at 13:28
Then your VPN is not allowing you to use up more than 1 IP address, which is fairly normal. You will need to go with the NAT mode. – Frands Hansen Feb 17 '11 at 19:02

I think you need to look at split-tunneling on your VPN which will allow you to access other networks on the local system. Duplicate?

share|improve this answer

I'm in a similar configuration.

Don't try the VPN over vboxnet0, what you need is to declare one of the 4 interfaces over eth0 in bridge mode.

It works well with Cisco VPN, running over a XP interface, when the bridge is on eth0. However when the bridge is over wlan0 : NO WAY.

I think you will find bug reports about this.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.