Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

This is a problem that has plagued my office for a few months now. It has bounced between our ISP (Comcast), our IT contractor, and even our VOIP contractor, each of which has "fixed" it at least once.

Originally, the problem was significantly worse than it is now, with sites constantly timing out of half their assets: Loading the DOM but only some of the images, or timing out on the CSS. That problem has become much rarer, but still, many times over the course of a day, a domain will simply fail to resolve after a wait.

Suspecting Comcast's DNS, I tried switching my workstation to Google DNS, and then OpenDNS, neither of which changed things: Now I'll just get the OpenDNS page telling me it can't resolve google.com.

And that's the part that perplexes me -- how can this problem transcend DNS providers?

share|improve this question
    
What is your network setup, and do you have any sort of QoS or filtering appliances in place? Firewalls? –  Dave Drager Feb 17 '11 at 21:11
    
Just a couple of Cisco managed switches and an RV082 VPN router. We shouldn't have any QoS or filtering rules set up. Could the VPN setup be causing problems? –  user54365 Feb 17 '11 at 23:22
    
I've been going crazy trying to debug my own network here too, and I'm pretty sure it's Comcast. I get almost the same results. Web browser doesn't resolve/load pages, DNS "nslookup" has no response whatsoever, but streaming services like Pandora and BitTorrent continue uninterrupted. (and I'm not talking about buffering) –  Eric Falsken Mar 11 '11 at 22:47

2 Answers 2

Do you have a firewall between your PCs and the internet that is doing some application (DNS) filtering? You might not even know it is doing it if it exists. It's possible the firewall is examining DNS requests and blocking stuff it thinks might be a security risk but isn't doing a great job of it. I've not personally seen this issue with DNS but it is a fairly common problem with, for instance, Cisco PIX interfering with SMTP when it thinks it is securing things but is really just getting in the way of normal communication (Cisco is awesome but the application filtering built into their firewalls is usually not so great).

share|improve this answer

Are you sure the problem is exclusive to DNS? It sounds to me like packets might be getting dropped irrespective of their content. If so, then you have a problem with your upstream provider (Comcast). Another question worth asking: If DNS times out, does it always time out on the same thing, or do multiple attempts at lookups eventually succeed?

As others have asked, what does your network look like? Network hardware, etc.

share|improve this answer
    
We did apparently have a packet loss issue earlier, which a Comcast tech addressed by replacing some minor upstream component in the building. Doing some pings right now, I get 0% packet loss, as long as it makes that first ping. Multiple attempts usually work, though the time it takes varies. –  user54365 Feb 17 '11 at 23:26
    
Actually, this is interesting... I've tried to ping cnn.com for a few minutes here, and have gotten 100% packet loss each time, yet HTTP seems to work fine. –  user54365 Feb 17 '11 at 23:36

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.