Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

hey, i installed phpmyadmin and I go to myip/phpmyadmin/ and sign in, but then it's telling me

The requested URL /phpmyadmin/index.php was not found on this server.

I'm running debian and any suggestions on getting it working would be greatly appreciated. Thanks

share|improve this question
add comment

3 Answers

up vote 2 down vote accepted

Try reconfigure to use Apache 2:

$ sudo dpkg-reconfigure phpmyadmin

Try purge phpmyadmin:

$ sudo apt-get purge phpmyadmin
$ sudo rm -rf /etc/phpmyadmin
$ sudo apt-get install phpmyadmin

Also(manual configure Apache2):

$ sudo ln -fvs /etc/phpmyadmin/apache.conf /etc/apache2/conf.d/phpmyadmin.conf
$ sudo service apache2 restart
share|improve this answer
    
tried that aswell as removing the package and reinstalling it multiple times. –  Belgin Fish Feb 17 '11 at 23:03
    
What output "ls -al /usr/share/phpmyadmin/index.php"? –  ooshro Feb 17 '11 at 23:05
    
-rw-r--r-- 1 root root 6586 2008-07-28 14:41 /usr/share/phpmyadmin/index.php –  Belgin Fish Feb 17 '11 at 23:07
    
What error in "/var/log/apache2/error.log"? –  ooshro Feb 17 '11 at 23:08
    
[Thu Feb 17 17:11:28 2011] [error] [client 173.206.129.30] File does not exist: /var/www/phpmyadmin, referer: 173.192.176.177/phpmyadmin –  Belgin Fish Feb 17 '11 at 23:11
show 2 more comments

Add this line:

Include /etc/phpmyadmin/apache.conf

To: /etc/apache2/apache2.conf

share|improve this answer
    
it's already there –  Belgin Fish Feb 17 '11 at 23:13
    
have you restarted apache? –  pablo Feb 17 '11 at 23:16
1  
better use symlink to /etc/phpmyadmin/apache.conf in /etc/apache2/conf.d directory –  ooshro Feb 17 '11 at 23:19
    
thanks ooshro just glad its fixed :) –  pablo Feb 17 '11 at 23:23
add comment

This solved my problem:

ln -s /etc/apache2/conf.d/phpmyadmin.conf /etc/apache2/conf-enabled/phpmyadmin.conf
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.