Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've been following this blog post so that I can share APC opcode cache between PHP processes using FastCGI. Unfortunately I'm getting the following error when starting httpd:

Starting httpd: Syntax error on line 4 of /etc/httpd/conf.d/mod_fastcgi.conf:
FastCgiWrapper: "/usr/sbin/suexec" execute access for server (uid -1, gid -1) failed: execute not allowed

Line 4 of mod_fastcgi.conf has FastCgiWrapper On. I notice that the documentation states that this line could specify the path to the wrapper. Should that be changed?

I've checked that the permissions of the user's php-fastcgi script (550) and directory (555) are correct, /usr/sbin/suexec is correct (-r-s--x---) and that suEXEC is being loaded by apache ([notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)).

Where else should I be looking? I'm pretty sure that this is a permissions or path issue...

TIA,
JD

share|improve this question
add comment

1 Answer

It's to do with the order of the directives. In conf/http.conf it includes conf.d/* before it specifies User and Group directives.

Try putting mod_fastcgi.conf in conf/ and at the end of httpd.conf append

Include conf/mod_fastcgi.conf
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.