Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

So we have a load balancer setup to pass off our http connections to an array of six servers .. I have disabled KeepAlive and for some reason, only after I restart apache, does my additional connections/requests get routed to a different server (random in the pool) .. any tips?

I'm 100% sure our load balancer is doing as it should with 0 persistence as any new connections get passed around without a problem.

share|improve this question
    
What load balancer are you using? It's not really possible to answer without knowing that. –  devicenull Feb 18 '11 at 3:30
    
Barracuda 340 with persistence disabled and routing requests evenly within the pool of 5 servers. –  hawaiian9d9 Feb 18 '11 at 3:38

1 Answer 1

If you're using mod_proxy_balancer then read the Apache documentation for the module which gives some tips at the end at diagnosing stickyness issues via the log.

Have you tried accessing the site from different clients to see if they get always get forwarded to the same server?

share|improve this answer
    
No mod_proxy_balancer running. Might be worth noting that we have enough modules for minimal operation and that's about it on all of our servers. Yes, I have tested from multiple servers and networks manually with browsers, a simple telnet to port 80 and using apaches ab tool. –  hawaiian9d9 Feb 18 '11 at 3:35

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.