Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Strange question here. I have a server with 1GB of RAM, however when booted this shows as 768MB. I've discovered the reason for it – and that is that it has an unboard graphics card which shares memory with main RAM. Running Ubuntu Server, it doesn't actually ever use anything graphical – it's all set up to be SSH'd into and therefore there's no need to use the VGA.

I believe there may be a setting to switch off VGA/graphics card in BIOS, but my question to you guys is:

  1. is this recommended? and
  2. if I turn it off, then how would I turn it back on again in BIOS (given that with it off, I wouldn't be able to see the option to turn it on as there would be no graphics output!!)?
share|improve this question
1  
Is it actually a Dell or HP server, or just a box you've repurposed as a server? –  Tom O'Connor Feb 19 '11 at 13:31
    
It's a Mini-ITX box repurposed as a server (Running Ubuntu Server 10.10)... –  Javawag Feb 19 '11 at 14:18
1  
This is just one of many problems you'll find when 're-purposing' desktop hardware as a 'server'... –  Chris S Feb 20 '11 at 16:02

3 Answers 3

up vote 7 down vote accepted

You won't be able to disable the VGA graphics in the bios unless you have a secondary card pci/agp graphics card installed. You might see the option, but it won't let you do it unless there is some other output. If your bios is fancy it might have a serial output in which case you might be able to disable the VGA, just be ready with a serial console if you ever need a display.

The thing to do is change the maximum shared memory value to be as small as possible. 4M, 8M, whatever it will let you move it down to. Once you turn down that shared memory space it isn't going to take up much on your system. If 32M of ram is going to make a difference in the life of your server, buy another gig and make it really happy!

share|improve this answer
    
Thanks! I've brought it down to minimum (32MB)... it does have a disable option but I don't think that's all that wise! I may add another 1GB stick though at some point, I'll see how it goes first though! –  Javawag Feb 19 '11 at 14:16

You may find this interesting, using the graphics adapter's RAM as a RAM disk.

http://en.gentoo-wiki.com/wiki/Using_Graphics_Card_Memory_as_Swap

Works great on my PowerEdge 2500.

share|improve this answer
1  
Interesting, but I don't think this applies for the person who asked the question since the whole problem is that their graphics adapter doesn't HAVE any ram and is sharing system ram instead. –  Caleb Feb 19 '11 at 16:40
    
yup, this doesn't apply to me due to it not having it's own memory as stated by Caleb. But it's an interesting read at least, something to bear in mind for the future :D –  Javawag Feb 20 '11 at 11:57

I'm not sure I'd worry about it. Linux is far better at managing RAM than you are. Let it do it's own thing.
If you have DRAC access (or similar) to the BIOS, then you might be able to disable the memory-sharing, or limit it down to 16MB (or so).

Seriously though, RAM is cheap. If you run out, buy more.

share|improve this answer
    
Yeah, we're down to 32MB now, leaving me 992MB RAM - this will do! More RAM is a possibility too, I'll see if I need it! –  Javawag Feb 19 '11 at 14:17

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.