Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have an account on a server that is not a super user. Because of this I've used RVM to install Ruby, and I've also installed a few gems.

However, the sqlite3-ruby gem does not want to install, since the sqlite3 binary is too old. I've downloaded a newer binary from the sqlite3 homepage, but I can't figure out how to point gem in the direction of the newer binary?

share|improve this question
add comment

2 Answers

Try to edit your PATH environment variable to have the directory where your own sqlite3 binary resides.

share|improve this answer
add comment

Use with-sqlite3-dir options:

$ gem install sqlite3
Fetching: sqlite3-1.3.3.gem (100%)
Building native extensions.  This could take a while...
ERROR:  Error installing sqlite3:
    ERROR: Failed to build gem native extension.

$ gem install sqlite3 -- --with-sqlite3-dir=/home/ooshro/usr
Building native extensions.  This could take a while...
Successfully installed sqlite3-1.3.3
1 gem installed
Installing ri documentation for sqlite3-1.3.3...
Installing RDoc documentation for sqlite3-1.3.3...

ls -R usr/
usr/:
include  lib  share

usr/include:
sqlite3ext.h  sqlite3.h

usr/lib:
libsqlite3.a  libsqlite3.la  libsqlite3.so  pkgconfig

usr/lib/pkgconfig:
sqlite3.pc

usr/share:
doc

usr/share/doc:
libsqlite3-dev

usr/share/doc/libsqlite3-dev:
changelog.Debian.gz  changelog.gz  changelog.html.gz  copyright  README

$ rvm list

rvm rubies

=> ruby-1.9.2-head [ i386 ]
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.