Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Is there a configuration setting I need to modify somewhere for this to work?

share|improve this question
    
Windows or Linux? –  BenGC Feb 19 '11 at 20:28
    
Mac os x snow leopard. –  Xavier Feb 19 '11 at 20:29
    
do you have the firewall enabled? if so you need to add an exception for 8080 –  BenGC Feb 19 '11 at 20:34
    
It wasn't the firewall it is turned off. Apparently the firewalls on os x are off by default O.o –  Xavier Feb 19 '11 at 20:37

2 Answers 2

I had the same issue and tomcat was returning a status 400. This was due to the fact that my tomcat installation did not have the following directory: tomcat\webapps\ROOT

Inside this directory is the index.html that is being looked for when http://localhost:8081 is requested.

Just something else to check.

share|improve this answer

Check you server configuration.

If the address var is set to 127.0.0.1 you wont be able to get to it via other addresses.

Change this to your IP address.

http://tomcat.apache.org/tomcat-5.5-doc/config/http.html

Should be in conf/server.xml.

Also it may be that your app is restricted to certain hosts.

Check point 10 in this link: http://oreilly.com/pub/a/java/archive/tomcat-tips.html?page=2

Hope this helps you.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.