Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm working with Amazon's EC2 for the first time.

I went through all of the steps at http://docs.amazonwebservices.com/AWSEC2/latest/GettingStartedGuide/ and now I'm trying to access the public DNS through a web browser. I get nothing. I don't even know if I'm supposed to get anything, really.

I just want to see something that indicates that my instance is accessible from the web for development's sake. I'm completely new at this and I can't find a simple answer to this anywhere to save my life.

Any help would be MUCH appreciated. Thanks!

share|improve this question

2 Answers 2

up vote 3 down vote accepted

The default is not allowed any connection to the instance. The same can not be installed Web server.

  • allow ssh(for UNIX) or RDP(for Windows) and HTTP
  • connect to the instance and install Web server
  • check public DNS through a web browser
share|improve this answer
    
How do i "install Web server"? –  Spencer Carnage Feb 20 '11 at 23:21
    
@Spencer What OS? –  ooshro Feb 20 '11 at 23:39
    
Yes. OS please. –  egorgry Feb 20 '11 at 23:53
    
I'm using a standard instance of Basic 64-bit Amazon Linux AMI 2010.11.1 Beta and accessing it via Putty from Windows XP. –  Spencer Carnage Feb 21 '11 at 0:02
    
Use yum to install Apache ot other web server(sudo yum install httpd ) –  ooshro Feb 21 '11 at 0:16

For those of you using Centos (and perhaps other linux distibutions), you need to make sure that its FW (iptables) allows for traffic on port 80 (or any other port you want). In order to test if its the machine's FW that's preventing access (as opposed to Amazon settings) try the following:

sudo service iptables stop
sudo chkconfig iptables off

Now test if you can access the machine. If thats the case then you'll need to open the specific ports your application needs. See here on how to do that.

to re-enable the rules just:

service iptables start
chkconfig iptables on
share|improve this answer
1  
Welcome to Server Fault! We really do prefer that answers have content, not pointers to content. This may theoretically answer the question however, it would be preferable to include the essential parts of the answer here, and provide the link for reference. This post will be removed if not improved. Thank you! –  Chris S May 21 '13 at 15:19
    
Thanks for the welcome! First, the important aspect in my answer is explicitly stated and that is that the AMI's FW might be the/an issue rather than any amazon related configuration. If the OP thinks this could be relevant then s/he can then click the links. Also importantly (IMO), the person/company that provides the information that I linked to, deserve the potential traffic. Last, Why not let the community moderate this in the sense that they click the answer up/down rather than forcefully remove it? If you still feel strongly about this I will post the verbatim of the suggested solution –  nsof May 22 '13 at 7:12
    
I see the AMI FW portion, it's a pointer to a problem, not an "Answer" per-se. Stack Exchange is not a forum, we try to require the Answer actually solve the problem (this doesn't always have to be the solution the OP was asking for). If that was all you had posted I would simply convert it to a Comment. If you check out the article I linked to it goes into detail why we don't allow links to content (dead links are a huge problem). I can appreciate wanting to provide the site owner with traffic, and reference links are required when you're using other people's content. But my canned message stands... –  Chris S May 22 '13 at 14:09

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.