Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

So on my Windows Server 2008 box, I have a DNS server installed on it. For some reason, every ten minutes or so, the Host (A) address for the computer keeps on changing to its internal private IP address. I want it to have its public address for Active Directory purposes, but it keeps changing itself back to the private IP address. Any idea as to why, and how to change it?

If it makes a difference, this is an Amazon EC2 server.

Thanks

share|improve this question
    
Is your box used for anything else beyond just a DNS server? Is it a domain controller, or anything like that? Any other services? –  Paul Kroon Feb 22 '11 at 3:35
    
Yup, its running Active Directory –  Chiggins Feb 22 '11 at 4:13

4 Answers 4

up vote 5 down vote accepted

Most likely you'll want to set the network adapter to not register the IP in DNS automatically. Check out the "How to modify DNS dynamic update behavior" section here (I know it says for Windows XP, but it's the same basic steps). If you choose to not have it register, that should prevent it from updating in DNS.

share|improve this answer
    
Alright, I unchecked the "Register this connections address in DNS" checkbox, but the 10.x private IP address was still applied to the HOST (A) entry for the computer. Did I miss something else? –  Chiggins Feb 21 '11 at 15:59
3  
Assuming I'm correct in your problem, that won't change it back to the IP you want, it will only prevent Windows from registering the IP again. You would need to change the record to what you want manually, and then Windows should not try and register it again. –  Paul Kroon Feb 21 '11 at 17:43
    
I unchecked the checkbox, and changed the DNS entry, but the DNS entry is still getting changed back to the 10.x IP address. –  Chiggins Feb 21 '11 at 18:42
    
Sounds like this is a more complicated setup, and will take some extra work. The first step that should change it is here: support.microsoft.com/kb/292822/EN-US. I found this through these two sites: support.microsoft.com/?id=275554 and forums.techarena.in/active-directory/954155.htm. This seems to cover the problem since this runs DNS and is a domain controller. However, because this seems to not be recommended and is complicated to change, for what reasons do you want to use the IPs in this way? Perhaps there is a more optimal solution for your main goal. –  Paul Kroon Feb 23 '11 at 2:20

Open Network Connections in the Control Panel; find the offending Local Area Connection, open it's properties, then the IPv4 properties, Advanced button, DNS tab, checkbox on that page "Register this connection's address in DNS" needs to be unchecked.

share|improve this answer
    
I've done this, and like I said with Paul Kroon's answer, I still keep getting the 10.x IP address. –  Chiggins Feb 22 '11 at 15:42
    
@Chiggins, tried bouncing the server? –  Chris S Feb 22 '11 at 17:36
    
I don't understand what you mean by that –  Chiggins Feb 22 '11 at 22:18
    
@Chiggins, sorry, regional colloquialism. Have you rebooted the server already? –  Chris S Feb 23 '11 at 1:38
    
Yup. I think I'm just gonna drop this and use a VPN on my machines for when they access AD, because even with this problem, I'm still having other network related problems while joining AD. Thanks a bunch for your help though. –  Chiggins Feb 23 '11 at 6:31

A lot of things automatically register themselves in an Active Directory environment.

… other answers have only pointed you at the things that workstation machines automatically register. You've set up a domain controller, with the DNS server rôle. That's two more server things that automatically register themselves in DNS right there: the netlogon service and the DNS server service. Ironically, it's those that have to be turned off, and this is a Frequently Given Answer that's roughly a decade old.

Further reading

share|improve this answer

Something like this happened on our servers too., I remember having created a CNAME and manually giving it the public IP. In another scenario, we ended up creating a mapping between

CNAME->another zone. and

another-zone->public IP (this worked because the IP was fixed - might not work if its DHCP )

share|improve this answer
    
why a downvote? –  user67714 Feb 22 '11 at 17:09
    
Hacking around the problem instead of fixing the configuration is definitively the Doing It Wrong™ –  Chris S Feb 8 '12 at 13:52

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.