Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to set up a reverse zone for the entire 10.200.x.x/16 subnet. I've configured everything according to named.conf and several different blog posts, but no luck.

Note that the A-records resolve correctly, the problem is reverse lookups.

Can anyone spot any configuration errors?

named.conf:

zone "200.10.in-addr.arpa" {
    type master;
    file "/etc/bind/master/10.200.reverse";
};

10.200.reverse:

$TTL 3600
@                       IN SOA  dhcpns01.guest.domain.com. admin.domain.com. (
                                2011022106 ; serial
                                10800      ; refresh (3 hours)
                                3600       ; retry (1 hour)
                                604800     ; expire (1 week)
                                38400      ; minimum (10 hours 40 minutes)
                                )
; name servers
                        NS      dhcpns01.guest.domain.com.
; hosts
0.10                    PTR     dhcpns01.guest.domain.com.

dig -t ptr 10.200.0.10 @127.0.0.1

;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NXDOMAIN, id: 15066
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 1, ADDITIONAL: 0

;; QUESTION SECTION:
;10.200.0.10.                   IN      PTR

;; AUTHORITY SECTION:
.                       10800   IN      SOA     a.root-servers.net. nstld.verisign-grs.com. 2011022001 1800 900 604800 86400

;; Query time: 11 msec
;; SERVER: 127.0.0.1#53(127.0.0.1)
;; WHEN: Mon Feb 21 12:19:31 2011
;; MSG SIZE  rcvd: 104

Disclaimer: This is edited down to be more viewable. I'm not using a single nameserver :)

share|improve this question
add comment

2 Answers 2

up vote 2 down vote accepted

It looks like your entry is for 10.200.10.0, not 10.200.0.10.

Try:

 10.0                    PTR     dhcpns01.guest.domain.com.

EDIT: You might want to try the dig like this:

dig -t ptr 10.0.200.10.in-addr.arpa. @127.0.0.1

OR

dig -x 10.200.0.10 @127.0.0.1
share|improve this answer
    
That worked, thank you! –  pauska Feb 21 '11 at 11:36
    
Try the amended dig (with the 10.0 PTR) –  Cakemox Feb 21 '11 at 11:36
add comment

Correct PTR to 10.200.0.10:

10.0                    PTR     dhcpns01.guest.domain.com.
share|improve this answer
    
See comment on Cakemox's answer –  pauska Feb 21 '11 at 11:37
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.