Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a very old Sparc Solaris network that was working fine last week, but after a power outage none of the workstations will boot.

The network looks like this: host A: solaris 2.6, shares /export/home to network by NFS host B: solaris 8, runs NIS server. Mounts /export/home/ by NFS. host C: RHEL5, shares /share to network by NFS. Mounts /export/home/ by NFS.

I figured that the main problem was host A, since you need the home directories available for the other workstations to boot(?). Host A does not mount anything by NFS as far as I know. However, this workstation will NOT boot. The OBP bootup sequence looks like this:

Boot device <blah>
configuring network interface le0
Hostname <hostname>
check file system <everything ok>
check ufs filesystem <everything ok>
NIS domainname is <name>
starting router discovery
starting rpc services: rpcbind keyserv ypbind done
setting default interface for multicast: add net 224.0.0.0: gateway <hostname>
<HANGS at this point>

Is there some kind of debug mode so that I can get more detail as to why the workstation won't boot? Is my network structure inherently susceptible to power outage? Is there a way I can boot up to command line so I can at least turn off the NFS mounting?

share|improve this question
    
There is a way to boot Solaris in verbose mode. And if the text scrolls by to quickly you can use Ctrl+S to pause it and Ctrl+Q to let it keep going. –  George Bailey Feb 21 '11 at 14:37
    
At the OK prompt boot -s will allow you to boot to single user mode which may get you in, boot -a is interactive mode which may help you find out what's hanging. –  Iain Feb 21 '11 at 14:37
    
How do I boot into verbose mode? boot -v??? –  joshxdr Feb 21 '11 at 14:41
    
Ok, I booted with boot -v, unfortunately the last line of bootup text is the same: setting default interface for multicast: add net 224.0.0.0: gateway <hostname> –  joshxdr Feb 21 '11 at 14:44
    
I tried boot -a, but the last line of bootup text is the same: setting default interface for multicast: add net 224.0.0.0: gateway <hostname> –  joshxdr Feb 21 '11 at 14:51

1 Answer 1

This problem was due to a failure of a foreground NFS volume to mount, due to the NFS volume being unavailable. To fix this I booted into single user mode (Thanks lain!) and modified vfstab so that it would not try to mount the volumes. Then I continued boot and everything came up fine. In the future I will use option bg (for baground mount) in vfstab, since the default is foreground which can cause boot problems.

share|improve this answer
1  
You previously wrote "Host A does not mount anything by NFS as far as I know." So was that a false assumption ? –  jlliagre Feb 21 '11 at 15:29

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.