Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to set up a Cisco test lab I have three routers and one switch:

  1. Cisco 2501
  2. Cisco 2513
  3. Cisco 3620
  4. Catalyst 1900

What I'm trying to do is to get the 2501 and 2513 on the net. Router #1 is the 2501; router #2 is the 2513.

I have all of the cable and adapters needed to get started.

Router 1 is connected to Router 2 with a serial cable; they use 10.0.0.0 "R1 10.0.0.2/8 and R2 10.0.0.1/8".

Router 1 acts as a DHCP server; its pool is 100.0.0.0. Router 1 is connected to the Catalys 1900 using eth0.

Router 2 is the DCE and the clock rate is set. Router 2 is connected to my home network on eth0.

RIP version 2 is being used.

I can ping router1 and 2 from my home network (192.168.1.0 "mycomputer 192.168.1.121/24").

I can ping a computer on the 100.0.0.0 network "testcomp 100.0.0.11/8". I can ping google from the following devices: mycomputer and router 2.

However, I cannot ping Google from the following devices: testcomp and router 1

Can someone tell me what I did wrong? I need every computer on the 100.0.0.0 network to be able to get onto the internet; here is my configuration:

        Router 2


    ACRS-R2#show config
    Using 602 out of 32762 bytes
    !
    version 11.3
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    !
    hostname ACRS-R2
    !
    enable secret 5 <REMOVED>
    !
    !
    !
    interface Ethernet0
     ip address 192.168.1.244 255.255.255.0
    !
    interface Serial0
     ip address 10.0.0.1 255.0.0.0
     no ip mroute-cache
     no fair-queue
     clockrate 64000
    !
    interface Serial1
     no ip address
     shutdown
    !
    interface TokenRing0
     no ip address
     shutdown
    !
    router rip
     version 2
     network 10.0.0.0
     network 192.168.1.0
    !
    ip default-gateway 192.168.1.254
    ip classless
    !
    !
    line con 0
    line aux 0
    line vty 0 4
     login
    !
    end

    ACRS-R2#
    Gateway of last resort is 192.168.1.254 to network 0.0.0.0

    R    100.0.0.0/8 [120/1] via 10.0.0.2, 00:00:04, Serial0
    C    10.0.0.0/8 is directly connected, Serial0
    C    192.168.1.0/24 is directly connected, Ethernet0
    R*   0.0.0.0/0 [120/1] via 192.168.1.254, 00:00:06, Ethernet0
    ACRS-R2#

    Router 1

    ACRS-R1#show conf
    Using 790 out of 32762 bytes
    !
    version 12.2
    service timestamps debug uptime
    service timestamps log uptime
    no service password-encryption
    !
    hostname ACRS-R1
    !
    enable secret 5 $ <REMOVED>
    !
    ip subnet-zero
    ip name-server 192.168.1.254
    ip dhcp excluded-address 100.0.0.1 100.0.0.10
    !
    ip dhcp pool ip100
       network 100.0.0.0 255.0.0.0
       dns-server 192.168.1.254
       default-router 100.0.0.1
       domain-name acrsnet
       netbios-name-server 192.168.1.254
       lease infinite
    !
    !
    !
    !
    interface Ethernet0
     ip address 100.0.0.1 255.0.0.0
    !
    interface Serial0
     ip address 10.0.0.2 255.0.0.0
    !
    interface Serial1
     no ip address
     shutdown
    !
    router rip
     version 2
     network 10.0.0.0
     network 100.0.0.0
    !
    ip default-gateway 10.0.0.1
    ip classless
    no ip http server
    !
    !
    !
    line con 0
    line aux 0
    line vty 0 4
     login
    !
    end

    ACRS-R1#
    Gateway of last resort is 10.0.0.1 to network 0.0.0.0

    C    100.0.0.0/8 is directly connected, Ethernet0
    C    10.0.0.0/8 is directly connected, Serial0
    R    192.168.1.0/24 [120/1] via 10.0.0.1, 00:00:09, Serial0
    R*   0.0.0.0/0 [120/2] via 10.0.0.1, 00:00:09, Serial0
    ACRS-R1#
share|improve this question
    
100.0.0.0/8 is an IP range that is routable to the internet. I would try changing that to something internal. See (en.wikipedia.org/wiki/Private_network) –  mpeterson Feb 21 '11 at 17:44
add comment

2 Answers

I don't see anything evident in your configs that would be causing the problem. Can you run a trace route from the 100.0.0.0 network all the way through the routers and to an external ip address? Can you resolve the name www.google.com from the 100.0.0.0 network?

share|improve this answer
    
@joeqwerty i changed the network to 11.0.0.0 when i ran the trace route it failed when it got to 2 launchmodem (192.168.1.254) 16 msec 16 msec 16 msec –  user71567 Feb 21 '11 at 20:38
    
As user70089 stated, your modem probably doesn't have a route to the 11 network. You'll need to add a satic route on the modem for the 11 network. –  joeqwerty Feb 22 '11 at 0:13
    
@joeqwerty my modem has a route to 11.0.0.0 –  user71567 Feb 23 '11 at 15:47
    
What is that route? –  joeqwerty Feb 23 '11 at 16:54
    
@joeqwerty I ran a trace route today when the trace route starts it hits 10.0.0.1 and then 192.168.1.254 the modem after that nothing happens trace route prints out ****** and then it just goes back to the router command prompt –  user71567 Feb 23 '11 at 17:12
show 2 more comments

How is your home network connected to the Internet? Is 192.168.1.254 your broadband router? If so, that sounds like it might need a route back to your 100.0.0.0 network via 192.168.1.244

As someone mentioned above, as 100.0.0.0/8 is a public address range, you might be better referring to RFC1918 and using one of the other private address ranges from there (perhaps making the 100 network 172.16.0.0/16 or similar).

share|improve this answer
    
@user70089 my home network is connected to the internet using a at&t dsl modem yes 192.168.1.254 is the ip address of the modem –  user71567 Feb 21 '11 at 20:40
    
Do you have NAT set up? Your DSL gateway will, probably, only allow NATing for a 192.168.1.0/24, so you will need to NAT yout 100.0.0.0/8 netblock into that (then to get NATed again, as it egresses through your DSL router). I'd also consider changing the 100/8 network to a /16 out of 172.16/12 –  Vatine Feb 24 '11 at 13:58
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.