Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm having some issues setting up and using a vhost.conf for one of my domains. So far none of the domains have required any extra configuration but now I need to use a PEAR module, so I'm looking to include /usr/share/pear in the PHP settings for the domain.

vhost file created in /var/www/vhosts/domain.com/conf/vhost.conf

<Directory /var/www/vhosts/domain.com/httpdocs>
 php_admin_value include_path ".:/usr/share/pear"
</Directory>

I then restart Plesk using:

/usr/local/psa/admin/sbin/websrvmng --reconfigure-vhost --vhost-name=domain.com

Or as plesk says that command is obsolete in Plesk 10 I've tried using

/usr/local/psa/admin/sbin/httpdmng --reconfigure-domain domain.com

And for good luck I've restarted apache too each time. Net result - none of the PEAR includes work unless I edit the include_path in /etc/php.ini!

Any tips on how to get this MOFO working? I've had a look through the documentation but TBH I just don't have time to read 40 pages of Plesk manual for one line of code, this can't be that hard, surely!

Thanks for any pointers, H

share|improve this question

closed as off-topic by Falcon Momot, mdpc, dawud, Jacob, RolandoMySQLDBA Apr 28 at 12:31

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "Questions must be relevant to professional system administration. Server Fault is dedicated to professional system and network administrators. End user and enthusiast questions are off-topic (contact your system administrator or hire a professional to help you out). Please see the Help Center for more information." – Falcon Momot, mdpc, dawud, Jacob, RolandoMySQLDBA
If this question can be reworded to fit the rules in the help center, please edit the question.

1  
Did you ever find the answer to this? I am having the exact same issue. I have added a vhost.conf but the settings never get applied. I don't get it. –  meschu Mar 9 '11 at 5:00
    
Hmm no I'm afraid - in the end we didn't need to use vhost.conf - I made a workaround within php.ini. It's annoying though, where the hell is the documentation for this? –  MrFidge Mar 15 '11 at 9:26
    
@hfidgen Please share the workaround, thanks! –  John Himmelman Aug 2 '11 at 19:34
    
Oof - yeah I'll try and dig that out for you! Sorry I normally do post back the answers. --EDIT-- Ahh it was simply to add in .:/usr/share/pear to the global php include_path. All our applications and domains on the server could make use of it safely so there was no absolute need to allow/deny it on a domain by domain basis. –  MrFidge Aug 3 '11 at 9:00

2 Answers 2

In Plesk 10, I typed:

/usr/local/psa/admin/sbin/websrvmng -a

And it worked. It outputs a message about it being deprecated, but it still works. The -a means reconfigure all domains.

share|improve this answer

Since this is one of the top results on Google for "plesk vhost.conf restart", and I could not find useful instructions elsewhere, I will share my experience.

I needed to add this to my Apache/Plesk configuration to allow larger uploads:

<IfModule mod_fcgid.c>
    FcgidMaxRequestLen 52428800
</IfModule>

So I put that exact content into a new file at:

/var/www/vhosts/domain.com/conf/vhost.conf

To get this file included in the Plesk-generated conf files, I used something like:

/usr/local/psa/admin/sbin/websrvmng --reconfigure-vhost --vhost-name=domain.com

or

/usr/local/psa/admin/sbin/httpdmng --reconfigure-domain domain.com

The result of these commands is that Plesk adds a line like this:

Include "/var/www/vhosts/domain.com/conf/vhost.conf*"

to the generated httpd.include file, such as

/var/www/vhosts/domain.com/conf/13494407390.45120500_httpd.include

I needed to restart apache for this to take effect:

/etc/init.d/httpd restart

And I checked the Apache error log to make sure it had no problems restarting.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.