Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a client that I do IT work for. They have a 2003 server with active directory and is setup as their DC. The problem they are having that just started over the weekend, is that they are unable to see any of the shares on the server. This started from one computer at first, and then as they started rebooting computers, those computers started having the same problem. Not all computers are having this problem though. There were a couple that I rebooted and renewed their IP leases, and they are still able to find the network shares on this server.

When we browse out to "\server\" instead of getting a listing of the shares on the server, they get a listing for just one folder called "users" and this folder contains nothing. If we try to manually enter the share name in the UNC path it comes back with an error saying it could not be found and to check our spelling. If I browse to \server\ from the server itself, it of course can see all its own shares.

OK, here is where it gets weird, I can browse to the server using just its IP address "\x.x.x.x\" and then we can see all the shares. I know that would look something like the workstations don't have proper DNS server settings in their IP setup, but if I go to a command prompt and ping the server by the server name, it pings it just fine, and returns the proper address. They have other network shares setup to other computers using just the computer names and all those work fine.

I think it has something to do with DNS, but at this point I am not sure what. I have tried flushing the DNS cache on the workstations. I have even tried running winsockfix to try and repair any issues with the tcpip stack. In order to get them back up and running, I am having to remap all their network drives to this server using the ip address of the server.

Any suggestions or solutions would be greatly appreciated.

share|improve this question

3 Answers 3

I resolved this by disabling offline files then re-enabling. Give it a shot.

share|improve this answer

Browsing shares via the NetBIOS name uses NetBIOS and SMB, not DNS. As a start make sure that NetBIOS over TCP is enabled on the workstations and the server. Make sure that the Workstation and Server services are started on the server and workstations. Make sure that File & Printer sharing is enabled on the NIC of the server (it should be as you're able to access the shares via the server ip address).

share|improve this answer

After you browser to the short name of the server from a workstation, enter the command

nbtstat -c

that should display the ip address of the short name that you are connected to.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.