Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Possible Duplicate:
How to Configure Windows Machine to Allow File Sharing with DNS Alias

Environment: Let's say my server name is OU812 and its IP address is 172.100.51.50. In DNS Manager I create a friendly CNAME record that user may more easily recognize that is VANHALEN (points to FQDN OU812.example.local).

Works (Windows 7 and 2008)

Using either Windows 7 or Windows 2008, I may enter all three values into the address bar of Windows Explorer to access shared resources on this server:

  • \\OU812 (works)
  • \\172.100.51.50 (works)
  • \\VANHALEN (works)

Doesn't Work (Windows XP and 2003)

Using either Windows XP or Windows 2003, however, only two of the three values work. The easy-to-remember CNAME record does not work:

  • \\OU812 (works)
  • \\172.100.51.50 (works)
  • \\VANHALEN (does not work)

Error Message (Windows XP and 2003)

Address Bar. Windows cannot find "\VANHALEN". Check the spelling and try again, or try searching for the item by clicking the Start button and then clicking Search. Ok.

Troubleshooting

  • From any OS, I can ping all addresses (OU812, IP, VANHALEN)
  • This Microsoft Hotfix doesn't help (http://support.microsoft.com/kb/950234)
  • Firewall is disabled on the server with the shared resources
  • Also attempted a DNS A record to the same IP address without success

Desired Solution

I would like for all Windows machines on the domain to be able to use friendly names in the Windows Explorer address bar. Our real naming convention isn't has cool as rock bands. Creating useful CNAME aliases that function in Explorer across all devices would be helpful. What steps have I overlooked? Thanks for the help.

share|improve this question

marked as duplicate by Chris S Mar 22 '12 at 18:39

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

1 Answer 1

up vote 1 down vote accepted

That sounds like DisableStrictNameChecking, but thats a server side setting. To my knowledge it shouldn't matter which client you try to use.

But its still probably worth looking into. Summary: servers don't respond to CNAMEs, unless DisableStrictNameChecking is set.

share|improve this answer
1  
This question has more detail about DisableStrictNameChecking. serverfault.com/questions/23823/… –  Zoredache Feb 22 '11 at 20:59
    
Thank you Steven and Zoredache. DisableStrickNameChecking was exactly what I was looking for. Michael Ferrante's documentation (serverfault.com/questions/23823/…) was easy to follow. Just had to reboot my "VANHALEN" server for the changes to take effect. –  Jason Pearce Feb 22 '11 at 21:26

Not the answer you're looking for? Browse other questions tagged or ask your own question.