Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I am using a Ubuntu virtual machine.Where I installed OpenACS which depends upon AOLServer.To do so I had first shutdown Apache on this machine and then as per instructions given here

http://openacs.org/xowiki/ubuntu

Step 1) aptitude install postgresql

Step 2) aptitude install openacs

I had to shutdown Apache to do above installation. Now the installation finishes.So I can access http://localhost:8000

but when ever I try to start Apache on this machine which was shutdown during installation I see the error

 service apache2 start
  * Starting web server apache2 (98)Address already in use: make_sock: could not bind to address 0.0.0.0:80  no listening sockets available, shutting down
Unable to open logs

So I thought may be OpenACS installs AOLServer so Aolserver might be listening on port 80 I check

 /etc/aolserver4/conf.d/openacs.sh 

and here

AOL_USER=www-data
AOL_GROUP=www-data
AOL_ADDRESS=192.168.1.15
AOL_PORT=8000
RUN_DAEMON=yes

So AOLServer is not listening on port 80 upto here it is confirmed.

  netstat -tualp  | grep 80
tcp  0      0 somemachine.somedimain.:8000 *:*   LISTEN   21321/aolserver4-ns

so netstat shows only 8000 in use. Then why am I unable to start Apache in this case?

Edit as ooshro below pointed out to check netstat -tualp | grep \:www the output
I got was
tcp 0 0 localhost:www *:* LISTEN 2883/aolserver4-nsd

share|improve this question

2 Answers 2

up vote 3 down vote accepted

To check:

netstat -tualpn | grep 80

or

netstat -tualp  | grep \:www

without 'n' options, 80 resolve to www.

Edit "/etc/aolserver4/aolserver4.tcl":

array set debian_config {
HOSTNAME localhost
ADDRESS 127.0.0.1
HTTP_PORT 8080
HTTPS_PORT 443
}

Then restart aolserver4 and apache2

/etc/init.d/aolserver4 restart
/etc/init.d/apache2 restart
share|improve this answer
    
you are right the second netstat showed me aolserver-nsd listening on www service. –  Registered User Feb 23 '11 at 13:36
    
@Registered User I update answer –  ooshro Feb 23 '11 at 14:14
    
I will bookmark your answer currently for me thing has worked. –  Registered User Feb 23 '11 at 21:56

Ok Finally I resoved this problem.The default openacs install listens on port 8000, to avoid conflict with the default aolserver listening on port 80.

I had to put RUN_DAEMON=no in /etc/default/aolserver4 file although all the lines of this file were commented out but I still needed to add

RUN_DAEMON=no

That is what worked for me.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.