Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We have Apache 2.2 running on Windows 2k3 and 2k8 R2 as a reverse proxy to downstream applications. Some of these applications may go offline during off-peak hours so we've implemented a custom 503 page like so:

ErrorDocument 503 /error/serverTimeout.html
ErrorDocument 504 /error/serverTimeout.html

(the error directory is in Apaches's htdocs folder)

If I make these changes, restart apache and then access the down application on firefox I see the custom page as expected. I then access it using my IE browser, it also works. If I close my IE browser and access it again, I get Apache's standard "Service Temporarily Unavailable" message instead of my custom page.

Once I receive the standard error message, I never get the custom page again until I restart Apache.

I've put the server on debug and I can't see any difference between the requests which return the custom error page and the requests which return the standard error message.

Is there some weird proxy setting which is messing with the errordocument configuration?

Any ideas?

share|improve this question
    
Are you sure that all error pages are coming from the frontend server? Take a look at Custom Apache ErrorDocument with proxy balancer & RewriteEngine –  coredump Feb 23 '11 at 23:09
    
We haven't got any RewriteCond in the configuration. We only use ProxyPass and ProxyPassReverse. There are no entries which relate to the error directory, so should be handled by the front facing server. –  jimmycavnz Feb 25 '11 at 1:46
    
It appears related to an OpenAM policy agent we have installed in apache: –  jimmycavnz Mar 1 '11 at 4:16

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.