Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My ex-system admin installed CSF on a server witout Admin panel. I can see CSF installed but I am not sure if its currently running or not. I dont want to try to start / stop it.

I realized there is no PID file concept in CSF and I am finding it hard to know if the server is currently running CSF or not.

share|improve this question
up vote 1 down vote accepted

Use "Firewall information" or "Check server security" in CSF.

Or run in shell(if firewall run output contain many rules)

sudo iptables -nv -L
share|improve this answer
if he has only rules in say nat table you wont see antything with that -nv -L – Hrvoje Špoljar Feb 24 '11 at 11:40
@HrvojeŠpoljar CSF don't support nat table. CSF control only filter table. – ooshro Feb 24 '11 at 11:44
heh well who knows what may or may not be there, OP mentions "ex-admin" you never know what someone left before you... – Hrvoje Špoljar Feb 24 '11 at 11:46
I tried using this command and got some enteries. How to be sure that CSF is running and the rules were not added manually – Sparsh Gupta Feb 25 '11 at 11:19
Block IP from CSF, then iptables -nv -L|grep BLOCKIP – ooshro Feb 25 '11 at 11:22



command and check out what output is.

share|improve this answer
root@vps ~/ # csf -l
csf and lfd have been disabled, use 'csf -e' to enable
root@vps ~/ # csf -e |head
DROP  tcp opt -- in * out *  ->  tcp dpt:67
DROP  udp opt -- in * out *  ->  udp dpt:67
DROP  tcp opt -- in * out *  ->  tcp dpt:68
DROP  udp opt -- in * out *  ->  udp dpt:68
DROP  tcp opt -- in * out *  ->  tcp dpt:111
DROP  udp opt -- in * out *  ->  udp dpt:111
DROP  tcp opt -- in * out *  ->  tcp dpt:113
DROP  udp opt -- in * out *  ->  udp dpt:113
DROP  tcp opt -- in * out *  ->  tcp dpts:135:139
DROP  udp opt -- in * out *  ->  udp dpts:135:139

I'm using "head" because I have VERBOSE enabled

 258 # Enable verbose output of iptables commands
 259 VERBOSE = "1"

If you change it to 0, you will get:

root@vps ~/ # csf -e
Starting lfd:[  OK  ]
csf and lfd have been enabled
root@vps ~/ #
share|improve this answer
Shit.. 2 years old ... Sorry – user319660 Nov 30 '13 at 16:41

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.