Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I’m having an issue with a Canon IR Advanced C2020 on the Mac side. We have the printer connected to the network and printing from Windows machines using the UFRII driver but I can’t seem to get any Macs printing to it. A quick rundown of relevant info:

  • It’s assigned a static IP which is pointed to by a hostname.
  • It only has UFRII installed, no other printing protocols.
  • We haven’t locked any ports on the machine down yet (including LPD/LPR)
  • Job accounting is turned on.
  • The Mac's are all running 10.6.x with the test machines I've been running at 10.6.6.

Troubleshooting steps taken thus far and their results:

  • I was getting an error that stated “Incorrect ID or Password; Specify the correct ID and Password.: 15513” however a Google search around this error wasn’t very helpful. I should also note that no Dept. ID prompt appeared before this error.
  • I changed the hostname to an IP address and the error above went away and it started prompting for a Dept. ID again. However when I would print something I would get the following error: “Printer in use. Waiting for the print job to finish” which appeared despite no print jobs running on the printer.
  • I’ve tried various different queue names from LP to LP1 to LPD to print and none of them changed the above behavior.
  • Disabling the firewall seemed to change the behavior from the 15513 error when a hostname is entered to the print queue error however when I tried that again this morning there was no change so that may have been an unrelated thing.
  • I’ve tried the PPD drivers which were useless.
  • When I disabled job accounting on the printer and tried to print after re-adding the printer sans job accounting I received the same error that the printer was in use.

I’m really hitting an idea wall and I was hoping someone out there might have an idea as to why this is happening and what I could do to fix it.

share|improve this question

2 Answers 2

up vote 2 down vote accepted

Turns out the issue was related to Bidirectional printing. You can go to Settings/Registration : Preferences : Network Settings > RAW Print Settings and make sure the two following settings are checked:

  • Use RAW
  • Use Bidirectional Communication

Just in case anyone else runs into this issue.

share|improve this answer

Had same error message on a Canon 6055/6065 BW Copier. Our fix was to open the printer utility on OSX (10.8.4) and and click "get printer information." Once the printer information showed, it was able to get bidirectional communication.

share|improve this answer

protected by Community Feb 20 '13 at 0:44

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.