Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm having very weird problem in my TS RDP connection,

I can copy and paste from my TS RDP out into my desktop (from any program into any program in my home workstation)

but somehow I cannot copy paste from my desktop into my TS RDP (from any program at all - it always remember the old content of the clipboard) ?

this is going through RDP session over Juniper SSL VPN into the Windows Server 2003 Terminal Server but obviously this is the same TS RDP application that is provided by Windows.

any help regarding this matter would be greatly appreciated.

Thanks,

share|improve this question

2 Answers 2

up vote 3 down vote accepted

Try this:

Go to Administrative Tools | Terminal Services Configuration. Right-click on RDP-TCP | Properties. Under the client settings tab, make sure "clipboard mapping" isn't checked.

share|improve this answer

On the 2003 server box, if you go to Administrative Tools | Terminal Services | Terminal Services Configuration right click on the "RDP-Tcp" connection in the Connections list and choose properties and then go to the Client Settings tab. Is the Clipboard option checked? If it is, uncheck it.

I have encountered weirdness like this from time to time, but rebooting my client machine usually solves it. If this is a consistent issue with this server it is likely a TS configuration issue.

share|improve this answer
    
why i need to unchecked it ? should it be checked to enable it ? –  Server System Specialist Feb 24 '11 at 22:53
1  
I've always found that very confusing too. The problem is that when you open up the RDP client it also has the option to sync the clipboard and I believe that is enabled by default when you open up mstsc and try to connect to a machine. The MSDN article on terminal services (technet.microsoft.com/en-us/library/cc770631%28WS.10%29.aspx) indicates that disabling the checkbox on the server side will disable all clipboard sharing even if the RDP client has the option enabled, but I have never found that to be the case. –  Diffuser Feb 25 '11 at 19:18
    
ah yes, thanks for your reply mate, I am now able to make it works after restarting the whole terminal server. –  Server System Specialist Mar 4 '11 at 13:15

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.