Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm having some problems installing CentOS 5.5 Final (i386) onto my server, a Cisco MCS 7800.

The problem comes very early into the installation. When the welcome screen comes up and gives you the option on how to boot into the DVD, I'll press enter to go into the graphical installer.

The screen will then have a blinking cursor in the top left of the screen and will never go away (I thought that it just might need time but I let it sit for over 5 hours). I then booted into it again and tried using Linux Text thinking it was a problem with the graphical installer. That didn't work, same problem.

Then I tried a DVD of RHEL 5 and got the same problem, both graphical and Linux text. At this point I think it's a hardware problem. The server has 2GB of ECC RAM, 1 Pentium 4 CPU @ 3.06GHZ and 2 WD Hard Drives (80GB) configured for RAID 0. (There is also an option in the BIOS for what OS type and that is set to Linux.)

If anyone has any idea what is going on, it would be helpful.

Edit Typing "text" doesn't change a thing. Still stuck at the blinking cursor. I looked it up and it's really the same thing as typing "linux text", which as stated in the first part of my question, I've already done.

share|improve this question

5 Answers 5

That machine is actually a rebadged HP DL360 G3, HERE are HP's RHEL 5 driver set.

share|improve this answer

That server is probably an HP ProLiant DL380 G3, which is well in the realm of support for RHEL/CentOS. Can you try the installation using text mode or maybe using the Integrated Lights-Out port?

share|improve this answer
    
I tried text mode, nothing changed. Any ideas? I also tried to install Ubuntu server and got the same problem... –  William Feb 25 '11 at 0:30

Try enter "text" after boot and use text installer.

share|improve this answer

I have the same machine, and I've been trying to netinstall kFreeBSD "Debian" on it for the last couple hours, but it was hanging early in the install when it got to Detect Network Hardware. And that was because the MCS 7800 uses dual Broadcom NIC's which aren't readily supported by the operating system. So I had to ask a friend to track down the file called 'tg3_tso.bin' and put it on a USB stick, then restart the install in 'Graphical Mode', and when that error comes up you are given an option to supply the file via a USB stick. Be sure that 'tg3_tso.bin' is the only file on that USB stick, otherwise it will shit the bed. Once it's done installing, you're ready to rock. Keep in mind that I'm talking about a netinstall of KFreeBSD here. you should give it a shot and see if you come across the same error. use google to find the kfreebsd download. if you don't know what kfbsd is, it's debian with a BSD kernel. epic win right? Good luck! lemme know if you have any questions!

share|improve this answer

In my case i reset the bios config to the default settings.

share|improve this answer
    
Adding a few more details would be beneficial. What bios settings had been changed, etc. –  squillman Jun 11 at 16:53

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.