Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to update my version of git that I'm using on the debian 5.0 lenny webserver (from 1.5 in the default package repository to at least 1.7 in the latest stable updates, according to the ubuntu ppa archives).

How would I add a repository to get a more stable version in Debian?

share|improve this question
add comment

2 Answers

up vote 4 down vote accepted

You can:

  1. Update your distro
  2. See if backports has the version you need and add lenny-backports to your apt
  3. Get the source package and rebuild it on your server (or on a Lenny machine, wich is more safe)
  4. Add squeeze repository to apt sources, then add the APT::Default-Release option to apt configuration and ask to install the new version. I will not describe that option in depth because I am very against it (and it will possibly break a lot of stuff) so only try that if you really want.
share|improve this answer
    
This, I found out just a bit ago, (should have refreshed) is true. –  Kzqai Feb 25 '11 at 0:16
    
@Tchalvak Thanks! :) –  coredump Feb 25 '11 at 0:18
add comment

Ah, found it, here:

http://backports.debian.org/Instructions/

Had to switch out "squeeze-backports" with "lenny-backports" before it would work, but it worked in the end, and got me up to version 1.7, so that's all I needed.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.