Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

This only happens to 1 of my machine, and only when booting into Windows 7.

No matter what network card I put in, Windows would default its mode to 10Mbps full duplex. Transfer speed is approximately 1 MB/s. If I set it to 100Mbps, the transfer drops to 100-200K/s. If I set it to 1000Mbps, the connection is lost completely.

I've tried swapping in different cards, both PCI-E and PCI. I'v etried update the windows, I've tried reinstalling the drivers...

On this very same machine, if I boot into Fedora, it can use the card at its full capacity 1000Mbps transfering 80+ MB/s

And all the cards work just fine when plugging into other machines on the same network.

I'm very curious. What could be the reason for this? The only different software that this machine has is virtual box with a VPN emulator, but disabling that VPN doesn't seem to do anything.

I would like to get this fixed, hopefully, without reinstalling windows >_< Will that be possible?

share|improve this question
1  
Does uninstalling the VM & VPN still do nothing? Clearly this isn't normal windows behaviour so it must be software that has been installed, and the VM/VPN is the obvious favourite. –  RobM Feb 25 '11 at 8:30
add comment

5 Answers

Have you made sure you have the correct drivers installed and that they are up to date?

Also, is Windows fully up to date and have you made sure that there are no other "problem" programs running such as malware/spyware/viruses etc?

share|improve this answer
    
I'm sure everything's up to date. But yea I haven't scanned for virus. I should do that. Thanks –  J Penguin Feb 25 '11 at 10:16
add comment

No matter what network card I put in

That tells me that, contrary to your heading, the card is not at fault. It sounds like something is screwed in the Windows networking system.

Right now you're trying to update a broken system, which normally results in an even ore broken one, rather than a fix. I suggest you run a repair on Windows. Either try and roll back to a previous restore point, assuming that things were in fact right at some earlier time, or perform an in-place reinstall of Windows. If neither of those work then nuke it and start from scratch.

share|improve this answer
add comment

Do you have other machine with the same hardware? If that shows the same problem, it can hopfully be resolved with a driver/firmware update. If the other board does not show the same symptom, you might have a faulty motherboard.

share|improve this answer
add comment

If these are all intel NICs, then make sure you are using the latest driver from the intel website instead of whatever the computer manufacturer or windows update says is the latest. I had this issue with two different machines with windows7 64bit and the driver direct from intel was the solution, even though I seemed to be using the latest driver according to the pc/mobo manuf website and windows update (which I do not use for driver updates anyway).

share|improve this answer
add comment

I have seen strange behavior for various network cards in Windows XP. Unclear to me why it happened, but very randomly they were dropping their connection. The best fix was to run Winsockxp_Fix or so. Maybe your case is similar (I am very unfamiliar with the newer Windows-es)?

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.