Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I tried to update my phpmyadmin to the newest version but now I get this error message when I try to access it:

Forbidden

You do not have permission to access this document.

I have a vps hosting with centos. Does anyone know how to fix this problem?

share|improve this question

2 Answers 2

up vote 1 down vote accepted

Sounds like the new phpMyAdmin directory has the wrong permissions. Try:

chown -R apache:apache /home/somewhere/phpMyAdmin

Obviously substitute in the appropriate path to phpMyAdmin. Also check what user Apache is using (could be apache, nobody, www, www-data, etc...).

share|improve this answer
    
Tried to run the command but nothing happened! –  Levani Feb 25 '11 at 13:18
    
If it worked nothing will appear to have happened. Look at the directory to see if the ownership has changed (ls -al /somewhere/phpMyAdmin). –  uesp Feb 25 '11 at 13:26
    
It could be wrong permissions, but it could also be other cases. You should look at the error logs, like @ooshro suggests. –  That Brazilian Guy May 26 '14 at 17:08

First you need to look the logs. In CentOS Apache write log in /var/log/httpd/.

If "/home/somewhere/phpMyAdmin" is symlink, add "Options FollowSymlinks" inside ...

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.