Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to migrate all of my domains from DNS Made Easy to Linodes DNS Manager. The easiest way I figured was the "Import a Zone" option on Linode, which works with AXFR. I then did the following (guied by this instructions):

On dnsmadeeasy.com:

  1. Activated "Zone Transfer Setting (AXFR ACL)" in the "Advanced DNS Settings"
  2. Went to "Zone Transfer Configuration" and added a "Zone Transfer Set (ACL)" named "Linode" and in "IPs to allow transfer" I added the ones required by Linode (based on this message: "Your nameserver must allow zone transfers (AXFR) from 69.164.199.240, 69.164.199.241, and 69.164.199.242"), each on its own line.
  3. I went to my domains list and applied the corresponding AXFR ACL.
  4. Waited for them to change from "Updating" status to "Active".

On manager.linode.com:

  1. Tried to import any domain zone, using axfr1.dnsmadeeasy.com and axfr2.dnsmadeeasy.com as the "Remote Nameserver", depending on the name server my domain was delegated to.
  2. Then it happens: Linode gives me a "AXFR Failed or the zone was empty!" error every time, only once I managed to get an "already listed domain" kind of error, because I was trying to import, well, and already (manually) imported domain. However, I could't even get the same error again.

What is that I'm missing?

share|improve this question
add comment

2 Answers

To narrow down the cause of the problem can you add a 4th IP that of your Linode to the AFXR ACL. After doing that the following commands should echo the DNS records on the screen.

host -l domain.com axfr1.dnsmadeeasy.com
host -l domain.com axfr2.dnsmadeeasy.com 

If this works it will confirm that dnseasy is providing the axfr's and there is a problem on Linode's end.

share|improve this answer
    
Thanks! I tried that locally and I could see the name servers listed, then I tried importing the same domain to Linode and it worked! I guess they weren't really updated on the DNS Made Easy side, I will continue with the others and we'll see. –  fandelost Feb 25 '11 at 18:07
add comment
up vote 0 down vote accepted

Done! For the record, it was partially Linodes fault because they apparently save in cache all the attempts to import a zone, including the unsuccessful ones.

My first attempt to import a domain was lacking some steps, so it naturally didn't work. The later attempts were supposed to work, but Linode was still using their cached version of the remote AFXR ACL, so they were no good.

To my surprise (at that time), importing the rest of the domains worked perfectly, so at last I tried again with the first (culprit of this question) domain, and it also worked!

Thank you Sameer for pointing me in the right direction to troubleshot it.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.