Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm having a really tough time getting the LDAP extensions to work in PHP on a WAMP server.

Here is what I've done:

  • Went to C:\Program Files\Apache Software Foundation\Apache2.2\modules and made sure that mod_ldap.so exists.
  • I've gone into C:\Program Files\Apache Software Foundation\Apache2.2\conf\httpd.conf and made sure that this line is not commented out: LoadModule ldap_module modules/mod_ldap.so
  • I've gone into C:\Program Files\PHP\php.ini and made sure this line is not commented out: extension=php_ldap.dll
  • I've made sure C:\Program Files\PHP is in the Path
  • I've made sure C:\Program Files\PHP contains libeay32.dll and ssleay32.dll
  • Restart apache

phpinfo() still doesn't show mod_ldap as being turned on. It shows util_ldap under Loaded Modules, but that's the only reference anywhere to LDAP.

For a bit more background, I originally posted this on SO.

share|improve this question
    
Did you try installing open LDAP on your Windows machine ? –  user110080 Feb 9 '12 at 16:19

1 Answer 1

One solution to this might be a full computer reboot? For a shorter option, try setting engine = On in php.ini to Off. Restart WAMP. (You'll find php isn't working anymore - if not, you've edited the wrong php.ini) Set it back to On. Restart WAMP. Say WTF very loudly and pull your hair out when it works.

Good luck!

share|improve this answer
    
You haven't actually explained why he would do any of the above - all you're accomplishing here is ensuring he's using the correct php.ini file. –  MikeyB Dec 14 '12 at 17:09

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.